Rigid body object behaves strange after removing "animated" keyframes from timeline

Hi there,

I have used the cell fracture addon to put an object into 600 fragments. I tried a bit with animation of the fragments as they should not underlie physics until I want to. A simpolified example:

Keyframe 0: all (rigid body) fragments start “dynamic”, “animated” and “deactivated” and have calculated mass

Keyframe 40: “animated” setting is still checked for all fragments

Keyframe 41: “animated” setting is unchecked for all fragments => fragments underlie physics and break apart what I do not want. I want to destroy them with another object seperately.


Then, I experimented with a new test project file, created another “cell fracture object” but did nothing on the keyframes, only let fragments start “dynamic” and “deactivated”. This actually works and fragments are waiting to get destroyed.

So, back to my original project, I removed all keyframes from the fragments and also unchecked the “animated” box but for some reason, physics is kicking in at the time when previously there were “animated” keyframes. I don’t understand, as there literally are no keyframes in the timeline but Blender behaves as there were some.

cell_physics

In the outline you can see that, besides the first fragment, the others" have an animation". But how can they, if I removed all keyframes.

Pretty sure, there is simple solution for that, right? Just want to save my object, dont want to create a new one.

This sounds like cached physics. Blender remembers the last way the physics sim ran. The next time you run it, it just checks this cache instead of recalculating everything all over again. It doesn’t replace the cache unless it recognizes that something important has changed. It is often not very good at recognizing that something important has changed (like deleting keyframes…)

But it could be baked physics as well. Look on properties/scene/rigid body world/cache. Click “delete all bakes”.

To clear the cache, got to frame 1, in object mode, select all the cubes, start a translation (‘g’) but esc cancel out of it. This should reset your rigid body physics cache.

I often wonder why there is no explicit operation to clear the cache… When I first starting doing this, it took me forever to figure out how to do it.

Hi, thank you for reply. There was no bake before and deleting bake, although there was none, did not help.
Moving fragments around (with cancelling did not help. Actally moving fragments around did not help either. Changing properties in the rigid body settings (friction, bounciness, mass) did not help. I am not sure, what I also tried, but at the end, it worked out for me. Sorry, that I cannot leave a reasonable hint here :-(.

I played also with the simulation start/end settings in the rigid body world, copied several times rigid body settings to my objects, set them to passive rigid body, switched back to active.