Rigid body simulation and linking

Ok, tried searching for this and found nothing.

Is it possible to run a rigid body simulation (The new kind, that does not run inside the game engine) in one file and link it into another file? As far as I can tell all the other physics systems work, but when you link a group of rigid body simulated objects they just sit there, stuck in their first frame. Interestingly enough if I add a rigid body world to the scene into which they are linked and set them up to use it they jump to the position they were in when I saved the source file, and then simulate within the current file from that position, which suggest that something about the original simulation is being linked. This looks very glitchy to me though, and I suspect the answer I am going to get is that there can only be a single rigid body simulation in any Blender file, hence linking can’t work. But thought it worth asking, in case there is some trick!

Whilst here, another question - anyone know if its possible to animate the time of a rigid body simulation, e.g. have it going forward, slow down, stop and then go backwards? Really a question of curiosity - I have no current use for such a technique :smiley:

Thank you all in advance.

Edit: Using space there is a ‘bake to keyframes’ operator that allows you to do it, though it is obviously a one-way operation. Not too bad as it can be done in a copy of the file, and everything else can be setup in advance, so going back and editing remains possible without a large amount of effort.

Right now you can have only one simulation per scene. This means that you can have multiple simulations in one file (by using the background scene option you can combine them) and you can link simulations as long as you link the entire scene.
Also as you mentioned you can bake simulations to keyframes to link single objects.

You can influence the speed of the simulation throught the “speed” property of the rigid body world. This only influences the sinulation and not the animation playback, so you can’t go backwards since you’d have to simulate backwards.

Thanks - will give both of those a try later. Didn’t consider linking an entire scene! (And didn’t know about this background scene option.) :slight_smile: