RigidBody meshes eject each other

Hello everyone,
I’m trying to make rose petals falling from a flower by usqing rigidbody simulation.
The problem is that cause of the proximity of the petals, the rigidbody simulation make them explode instead of making them fall one by one in a natural way…
I can not upload the video, or the screenshot of my physics settings but they are the rigidbody basics one.
If anybody have a solution to avoid the proximity ejection, or an other way to make the falling works i will be very grateful.
(sorry for my english i’m french trying by best:))

Thanks a lot !

Hi @a33 ,

Try using cloth instead, then you will not have this problem.

Rigid bodies are not so easy to control at small sizes.

1 Like

Is there a way to make cloth simulation rigid as a rigidbody ?

some presents here, I’d start with something close like leather…

ok cool imma try this ! thanks a lot

1 Like

I tried the cloth simulation but i can’t make it rigid as the rigidbody without having very weird mouvment in my petals.
The collision are a mess and it’s so long to make test and to cache everything…

Is there really no solution to make the rigidbody works ?

Depends on yr setup, are you using an emitter for the petals?

Best to post at least what you have, so people can help you.

wierd movement happens alot, depending on yr setup or needs, there a ways to cheat this away. But it all depends on your use case.

Hi.
You share the .blend file here. As simple as the scene or setup may seem, there may be something you may have overlooked.

You can share .blend files up to 5MB here in the forum, or if they are a bit larger you can share it from here:
https://pasteall.org/blend/

Okok here is my .blend : https://pasteall.org/blend/9af7abf4d910412fb1d0acddb5dc99f9
I don’t have any emitter i’m just trying to make petals meshes falls from the top of the flower, as if the flower faded and the petals stand out one by one.

Your mesh is intersecting, in many places.

Yes i tried to seperate the petals but even when they are not in contact they eject each other.
The only way working is seperate them to much to keep the natural look of the flower

You could separate them with different collision,s collections.

You working with the file where there is no overlapping. Select all the flower elements corresponding to the Rigid Body Active type, leaving one of them selected as active element. From now on you should work that way leaving the elements selected:
From Object Menu, Set Origin → Origin to Center of Mass (surface). From Object menu, Apply → Scale. From Object menu, Relations → Make Single User → Object Animation.
From the Physics Properties Tab, in Rigid Body set Shape to Mesh. Right Mouse Button (RMB) on that Mesh field, and select Copy to Selected. In Sensitivity item, set Margin = 0.01 and RMB and Copy to Selected.
In the Scene Properties tab, in Rigid Body Settings you play with small values ​​in Substeps Per Frame (e.g. = 2) and Solver iterations (e.g. = 5). And you increase the Speed ​​to ~ 1 or 2.
Now, maybe you need keyframe “Dynamic” property in Rigid Body settings of the petals in each layer of three petals starting from outside to inside, with approximately 5 to 10 frames of difference between each layer. Dynamic disabled up to frame 175, and Dynamic enabled incrementally from frame 175 for each layer of three petals (for example the first outer layer of 3 petals with Dynamic enabled from frame 175, the next layer of 3 petals with Dynamic enabled from frame 185, and so on until the last inner layer). To work comfortably, Hide in viewport the layer of petals in which you have already set keyframes. Also you disable Rigid Body World in Scene Properties tab until you finish the job. This can be a bit tedious to do.

By the way, I think Soft Body would be more suitable for this kind of simulation. But it is too heavy to process in Blender and I have no experience with it.

Edit:
Remove collision of “TIGE” object and set Rigid Body “Passive” type.