RigidBody without game engine

Tried out the new rigidbody physics tab in blender and absolutely astounded by the results.
I could bake 250 frames of simulation with 8000 cubes in just 4.5 minutes!
Anyway, here is the finished result, I apologize for disappearing cubes, I don’t know how to fix it when a camera is too far to shoot things. There is a blend file at the bottom of this post, feel free to change the settings and run tests of your own. I know there is much more to do with the rigidbody solver but I was glad with the result and the simplicity of using it. All I did was change plane to passive in the “Type:” setting and check collision margin that has a default of 0.040 which works just fine for one or two objects(correct me if I’m wrong), but since weight was 4000X8000 cubes I use a setting of 0.250. With the cube I changed the mass to 4000 for testing and forgot to change it back to 20. Many Shift-D’s later I came to the result you see in front of you. Just hit bake and wait. That’s it. Hope to see what you all do with it.

Tip: Some of the essential rigid body functions such as the cache are found under the “Scene” tab.

Blend file too big so I pasted it on pasteall

To fix the problem of disappearing cubes, or anything disappearing really, select your camera, then in the “Object Data” tab (looks like an old school video camera) scroll down and you will see where you can add depth of field, lens angles, different camera types (RED camera, Nikkon, Sony, ect.), sensors, even different guides like the golden ration, crosshairs, ect., the thing you’re looking for is under the lens settings though, it’s the clipping, the end clipping needs to be set higher, I usually put mine at 1000.

I have a question for you though, how’d you set it up?

Thanks for the tip, I’m sure I’ll use it often. As to your question, What exactly do you mean by “set it up”?