Rigify finger rotation axis problem

Hello everyone,
I try to rig a character with rigify in Blender 2.8 and I don’t if it is a bug.
After adjusting the bones to my character, I do not have the same rolls on the rig that on the meta rig . That is disturbing, mostly for the fingers.
Do you have an idea to fix this?

1 Like

Same… Help!

Finally found a solution to this after a few days of searching!

With your metarig selected go into POSE MODE (This will not work in edit or object mode). Look at the side bar and navigate to the bone panel, then change the bone roll alignment setting from automatic to manual. The bones will now rotate based on the bone axis alignment from the metarig when the rig is generated.

This option will only appear for the finger bones shown selected in the picture below (you have to change the setting for each one individually).

As for the why: (Please correct me if I’m wrong)
From 2.79+ Rigify changed to use an automatic bone roll calculation (Ignores the metarig) that was supposed to make it easier to have working fingers without having to go through and manually change the bone rolls yourself, but it doesn’t always seem to work exactly as you would expect.

Also if anyone using blender 2.79 happens to stumble upon this same issue and doesn’t know how to fix it this post might be helpful.

Hope this helps anyone with the same issue!


Many thanks!

hi, i can not find this “Bone roll” Option! i select my bones as you did but option dose not show up!
help please

The option will only appear in pose mode for your armature Morteza. Are you sure you’re not trying to find this option in object or edit mode?

UPDATE: I’ve experimented with setting it to “x manual”. Seems to be working well. However, still curious on your answer.

Thank you for the info. Re: the manual setting, which did you choose?

Hello, long time I didn’t see this post. I chosed “x manual” too for the fingers. I must to do it also for the arms.

Thank you so much! This post helped me to fix this annoying issue. I now have a functional rig :heart_eyes:

You absolutely saved my life, ive been looking for a solution for 1 million years.

For me, setting “super finger” to Z manual worked. You have to display the bones axis names and look at the desired orientation.

I know this is old, but, THANKS SO MUCH!!!

Thank you, mister! I had this problem for some months now. Wish I had found this topic sooner.
I set X Manual for both thumbs and let other fingers in Automatic, as there were nothing wrong with them.

Oh! And it does work after “preprocess/Build skeleton” steps on Uefy 2.0 plugin workflow, in case someone wants to know.

Noticed middle and ring fingers were a bit broken so I just set everything to X Manual and everything is ok now.