Rigify in current 2.8

hi all,

i have been using 2.8 alpha-beta versions for a few months.
i remember rigify was usable before (one of 2.8 beta builds)
but today i tried to use it on a new character model i couldnt find it anywhere.

when i tried on a new computer therer .py errors as soon as i tick rigify in add-on menu.
on old computer (where rigify was previously installed)
when i Shift - A,
i couldnt find any meta rig armatures on the menu (only 1 single bone creation available)

i thought 2.8 was near finish,
can someone confirm please im in the middle of a case,

thank you for your time,

I do see changes to rigify go by every few days so it’s being actively improved for 2.80.

It shows up for me as an official bundled addon in the Community category under the Rigging type in the current 2.80.

However it currently fails to load for me with class register python errors, so something has gotten broken I suspect and you probably got unlucky and downloaded a temporarily broken version. I’ll go bug it…

https://developer.blender.org/T62976

Ok, the loading issue has now been fixed, however there’s a compatibility issue where the python scripts generated by Rigify when you create a rig also need to be updated, so for existing rigs you will need to have Rigify re-generate those scripts for you.

If you’re creating a new rig from scratch you should not have any issues.

The fix should be in tonight’s build available tomorrow.

1 Like

yes sir it came back in the latest build,
things can get desperate when something essential suddenly disappears.
thanks again and have a good day.