Rigify Meta-Rig for MB-Lab [Addon for an Addon]

rigging
add-ons
blender2-80

(DanielEngler) #1

This add-on adds a nearly ready-to-use Rigify Meta-Rig for Characters made with the MB-Lab add-on.

After the installation you can find the add-on in the MB-Lab tab in the Properties panel.

usage:

  • create and finalize a character with MB-Lab
  • select the Armature (usually “MBlab_sk<long number>”) in Object Mode (the menu doesn’t show in Pose Mode!)
  • click the button “Add Meta-Rig”
    optional:
    • set legs straight and adjust knee offset in y direction (I couldn’t get the rig to work properly without this. The knees always bend inwards.)
  • also optional:
    • remove face rig, if not needed
  • Generate Rig (Properties > Data)

to use the weight paint from MB-Lab:

  • select the character mesh
  • exchange the armature object (Properties > Modifiers)
  • click the button “MB-Lab to Rigify”
  • Weight paint for the neck bones “DEF-spine.004” and “DEF-spine.005” needs to be done manually

Important:

Weight paint for the neck bones “DEF-spine.004” and “DEF-spine.005” needs to be done manually! MB-Lab rig has one neck bone. The default Rigify rig has two neck bones.
Also, the head of “spine-004” should be moved a bit forward, before generating the rig.

Rigify in Legacy Mode: Weight paint for ‘thumb.01.L.01’, ‘thumb.01.L.02’, ‘thumb.01.R.01’, and ‘thumb.01.L.02’ needs to be done manually!


update 0.5.3:
fixed: renaming vertex groups for legacy mode

update 0.5.2:
fixed: renaming vertex groups

update 0.5.1:
added Rigify Legacy Mode compatibility

update 0.5.0:
port to blender 2.8 for MB-Lab


MB-Lab 1.7.3 Release for Blender 2.80
Meta-Rig for Manuel Bastioni Lab [Addon for an Addon]
(Safetyman) #2

Thank you!


(DanielEngler) #3

update 0.5.1:
added Rigify Legacy Mode compatibility


(micro26) #4

Hi, i tried to transfer weights from mb to rigify but seems there are bones missing from vertex groups.Mb has fewer bones than rigify that deform. Am i doing something wrong?
Bw i tested on 2.8


(Peetie) #5

Could it be you mean this: (see one of the previous posts): Weight paint for the neck bones “DEF-spine.004” and “DEF-spine.005” needs to be done manually! MB-Lab rig has one neck bone. The default Rigify rig has two neck bones.


#6

I am wondering if I should split that neck bone. Not sure what it will break if I do something like that…


(micro26) #7

I can merge the vertex groups but though i did something wrong. Anyway thx for this awesome addon!


(DanielEngler) #8

After using the “Rename Vertex Groups” function, you need to do some work. I updated the initial post, to make it more clear what to do.


(Entus_Brutalus) #9

The addon is nice but I have one bug the arms are not riged after klick MBlab rig to Rigyfy rig 2.7.9 and 2.8


(DanielEngler) #10

This should be fixed with version 0.5.3.

Maybe you where unlucky and downloaded version 0.5.2. It had a bug in renaming vertex groups and was online for just 2 hours.


(Per Olsen) #11

Thanks! I am all new to Blender, but I finanlly found this - not by using “View3D”/tools - but using shortcut key N.

However I also added the Rigify, and that gives four buttons to press… the first ‘Add Meta rig’ reports “Missing”, when hovering over. The other two, i do not know what they actually do…

When i click the Add button i get this:


(DanielEngler) #12

Thanks for the bug report! I’ll fix it.

edit:
update 0.5.4:
check if Rigify add-on is enabled


(Per Olsen) #13

Still no luck - perhaps the versions does not match? This is tree different cuts regarding this…

(disregard the paint part… got too much when i cut/paste… :wink: )


(DanielEngler) #14

Well, I forgot to write the description. I just wrote bl_description = "MISSING" in the code and forgot about it. That was unintentional trolling. :rofl: Sorry!

Just ignore the text.


(Per Olsen) #15

Thanks - I still run into problems! However I think your not to blame… where do I find more on using Rigify?


(DanielEngler) #16

DanPro has a lot of videos about Rigify on his youtube channel: https://www.youtube.com/user/Dantreige


(Per Olsen) #17

Thanks - just in case, can you tell me why i can not parent two objects. In 2.79 you can drop one object on the other… and it will be shown. In 2.8 you can either link or parent, but you can not see that it is done. Also when you export it… the two objects are separated - drives me nuts!

Found that in that view you can not see the parrenting - you need to go to the other view in the same panel, forgot what it is called… still a silly newbi…