Rigify Rigging Issues

I am rigging a character using the Rigify addon. For the most part, everything is going very well. After having a bit of trouble with the updated version of Rigify, I enabled legacy Mode in the plugin and started again. This is a direct result of me being unable to find any tutorials on the current version of Rigify, as well as the fact the finger widgets appear to have been removed (a feature I would very much like to take advantage of). Everything is going smoothly, except for one issue: I cannot get the character’s particle hair to follow the rig. In order to give as much information as possible, I am going step-by-step to describe what I have done.

  1. I added the meta-rig and lined it up with the character.
  2. I generated the Rigify rig.
  3. I activated the layer with the DEF bones and selected them all.
  4. I parented them to the character with Automatic Weights.
  5. I fine-tuned the rigging of the character. Currently there are no flaws in the rig and the character moves how I want him to.
  6. I began to parent parts of the character that are not part of the same mesh (e.g. eyeballs, items on the tool-belt) to the DEF bones, with no issues.

Everything has been working exceptionally well, except for two problems:

  1. The particle hair does not follow the rig. At all. I attempted to fix this using an Armature modifier (placed above the particle system modifier), but upon selecting the rig in the modifier, everything broke. For example, any arm movements would now move the mesh twice the distance I moved the rig. Attempts at IK suddenly deformed the arms. Most notably, the particle hair did indeed begin to follow the rig, but at about half the speed the character’s head did. It seems automatic weights and Armature modifiers have some sort of quarrel with each other, although I have rigged this character successfully in the past (I am upgrading him to a Rigify rig) so I am unsure what the problem is.

  2. The box-shaped bone that acts as the character’s hips does not simply move the hips up, down, side-to-side, etc. like it is supposed to. Instead, it moves every bone in the rig, same as the base widget with the multidirectional arrows. I am unsure if I have missed something, but as far as I can tell, if I add a metarig and generate the Rigify rig even with no character to rig, this still happens. This is the one bone in the entire rig that does not seem to work as it does in the tutorials. Is this a side effect of Legacy Mode, or is there actually something I’m missing?

Thanks in advance for any and all responses; I am still learning rigging, so all feedback is welcome!

I don’t have much experience with rigging particle hair, sorry. If the particles are generated from the head of the character, and the head is working with the rig, I don’t understand why the hair wouldn’t move with it – I have no knowledge as to why this would occur.

For the other issue – Not sure why that’s happening without examining the generated rig. What I usually do is add a Basic Metarig, then rigify that. It still gives you the updated rig but without the facial bones. Moving the square you speak of (torso) is supposed to move everything except the IK hands and feet.

For the second thing, I understand now. It’s because I didn’t have IK activated. it is working properly, I just didn’t have the rig in the proper mode - oops!

As for the particle hair issue, I still don’t quite understand why this issue even exists. As I said before, I have rigged this character successfully in the past, I’m simply updating his rig now. The particle hair is indeed generated from a vertex group on the character’s head, but the particle hair does not want to follow. Here are a couple screenshots to illustrate the problems:

Above: DEF bones parented to character with Automatic Weights, nothing in Armature modifier yet
Below: Rig selected in Armature modifier, hair now somewhat follows head, entire rig (especially IK) messed up.

You didn’t supply a blend. So just guessing, your modifier stack has the armature below the particle system. Put it above the particle system. Also, in future, you can post a blend cleaned up so it just shows the issue here. http://pasteall.org/blend/

My bad, I keep forgetting to upload the blend file when I post these. Here is the link to download the file.

Simple fix – move the armature modifier to the very top in the modifier stack. Since the armature controls everything, I usually move it to the top, and sub-d’s are usually the very last thing in the stack since I don’t need that affecting everything below it.

That still doesn’t quite fix it on my end… as you can see, the hair is following the rig, but too slowly, and the whole rig is messed up. But if I remove the rig from the Armature modifier, the hair doesn’t move with his head at all.

You have two armature modifiers that is causing problems. Look for the armature modifier that is red. Delete it. (Red means is doesn’t work.) Then move the armature modifier that is left up to the top of the stack using the little arrows. It almost always need to be first. If you don’t know what move the armature modifier to the top of the stack is, it means select your mesh go to the modifier tab, the little wrench in the property window, and click on it.

Ah, I see. I will take a look at this when I get a chance. Thanks!

UPDATE: This fixed it! I didn’t notice there was a second armature modifier at the bottom until you said that. The character used to have two particle systems, one for hair and one for eyebrows. I deleted the eyebrows one and decided to go the texturing route for them, and I assumed the last modifier in the stack was leftover from that. Thank you very much, the rig is working perfectly now!