Rigify seems to generate too much

Hello all,

 I have been trying to use the Rigify modifier, and so, I have placed the entire meta-rig and I am ready to generate the rig.  But whenever I generate the rig, it seems to generate too many things.  I've consulted several tutorials, and they all show something different.  I'm certain that I am doing something wrong, however, I cannot deduce what is wrong.  I'll attach a .blend file for anyone who wants to look into the problem further.  Thank you!

 Sincerely, Keto.

The Blend (Ready for generation): Human.blend (1.93 MB)

your blend files seems already select all scene layers (not rigfy bones layer)

then if you generate rig, it auto assgined generate amature, for all layers. to avoid it,
you need re-select all layer (by drug on layer then turn off), after that, select only one layer which you hope to assgin generate amature.

By “too many things” do you mean the controls that are generated? If so, that’s supposed to happen. But you can switch off the visibility of the generated rigs/controls. Use the small UI that appears on the properties panel to choose what you’d prefer to work with. Many of the “things” that appear aren’t meant to be interacted with, but they’re required for the rig to function correctly. Like the deformation rig on layer 30.

If you like you can limit yourself to using ik controllers. Something I usually do myself.

Check out Danpro’s videos regarding rigify, if you haven’t already. :slight_smile:

Okay, I’ve officially fixed all of my problems. So, the problem with having all of my layers selected was a definite issue, but after that, none of my finger, toe, arm, or leg bones would be made; so, just make sure that “Auto-Run Python scripts” is enabled in the user settings.