RIGIFY shows up a Generate message to set up the Shapes. Can it be repeated?

I hope Mr Horseman or other experts get to see this.

  1. I uploaded a blend file in www.pasteall.org but on completion it shows my file name instead of a reference number. How come?

  2. RIGIFY is a great tool. You fit the metarig bones to your character and in the Object data panel a special tab ‘Rig Layers’ appears with a single option ‘Generate’. Click this and all your Shapes are generated.
    Now for my query: suppose your rig turns out to be unsatisfactory because of a poorly fitted metarig, can one go back to the metarig and refit the flawed parts? I see that the ‘Generate’ option does not appear again.
    So must one again add a fresh metarig and start all over again?

I hope I have stated my query clearly enough. Help will be much appreciated.

  1. I dunno if I’m an expert, but thank you.

  2. That’s correct. The reference number you’re thinking of only exists in the URL itself. Just copy the URL from the address bar of your browser to share it.

  3. Are you sure? I just tested and I’m able to generate and re-generate from the same metarig to my heart’s content. Make sure you’re selecting the right object and not either the bone shapes or the Rigify armature. By default, after generating you should have two objects, “metarig” and “rig.” rig won’t generate anything, but metarig will. Make sure you’re using an up-to-date version of Blender directly downloaded from blender.org and not a Linux repository version.

Hi Horseman, your remarks are very encouraging. My blender version is 2.69 downloaded directly from blender.org.
I still don’t see the ‘generate’ slot in the Object Data panel for metarig. And the PasteAll is still a mystery to me.
So am attaching a screen shot of both and I’d be most grateful for your further explanation.

Probably just need to turn Rigify on again in Userprefs > Addons. It won’t stay on after closing Blender if not a saved userpref setting. Addon’s on/off are not changed by opening a file with the Load UI option.


Larry, how right you are to advise that Rigify must be turned on after closing the file.
I had rigified a model yesterday except for the fingers. I closed the file and re-opened it this morning.
There was no sign of the ‘generate’ tab. So I went to User Prefs and enabled Rigify again.
Sure enough, ‘generate’ was back !! Phew.
Thanks, Larry.