Rigify won't work ... uh ... help?

I was kind of interested in tinkering around with rigging in blender

the tutorial says to hit this button to generate this thingymajiggy
but then I get this error …

I’m not certain what this is or how to accommodate for it
um … help?

I had the same problem.
The base of “spine.004” (the neck bone) needs the be in the same location as the tail of “spine.003” (the chest bone):

Simply put then exactly in the same location:

You can select both the tail and the base of the bones and scale it to 0.
I hope this helps :grin:


perfect, thanks.
you know you follow these online tutorials and they explain how to do these things as if everything were running smoothly but if you have a small problem like that they don’t explain how to accommodate for it :confused:

1 Like

now it’s saying this …

Ok, that’s new, I don’t have any idea. Are you sure you didn’t accidentally delete any bone?

Actually, in moments like this, I just delete the armature and start all over again ¯_(ツ)_/¯

ok I see the problem now … there’s an extra bone that i needed to remove

(i don’t really understand why that would cause a problem though. there were other face bones on the original armature that I removed … cause the tutorial told me to remove em …

I can only guess that whatever bone was left that i failed to remove had … something … connecting to a bone i had deleted, and because it wasn’t their when generating the thing it returned an error

something like that)

Oh yeah I forgot, you can’t add bones in Rigify, at least not in the traditional way… Rigify confuses me sometimes lol

so rigify worked …
then generating the rig controls thing worked
and I played around with the rig controls a little bit, trying to figure out how to do stuff with it
but now this happens …

it’s like certain elements of the model aren’t getting … ‘parented’ … to the rig or something

i had an issue like this before when parenting the mesh to the metarig, i fixed it by editing the weights
but i don’t seem to be able to do that with the rig … controller … thing

I’m not certain why this is happening or how to fix this

Hey Douglas,
it’s hard to say what’s wrong from the info you shared. If you don’t mind sending me the model I’d like to take a look and find out what’s wrong. I’ll handle it with care :slight_smile:

Perhaps a bit of a shameless plug but I’ve been working on a Rigify tutorial series. I am still working on polishing the content but new chapters will be coming every week.

My goal with these tutorials is to cover all the quirks of the system. The problems you were experiencing earlier with disconnected bones etc are definitely covered.

So yeah, if you are able to send me the model shoot me a message. If not no problem of course.

Oh I already fixed that problem … like … a week ago. I’ve been meaning to get back to this forum post.

when you create and parent the first rigify rig to the model sometimes this happens if their are floating detached elements in your mesh (even if all the geometry is in the same mesh … object … thing)
that can be fixed by modifying the skin weights

so then when you add the spline controller things for your rigify mesh a sort of second skin gets created and this problem can occur again with the second skin

apparently their are different skins, you can go back and fix the second skin
(i’ll add pictures later describing what i’m talking about)

now it’s saying this …

what the hell … im starting to get frustrated
nothing seems to work the way it’s supposed to :frowning: