Rogue Material Block

Hi guys, while working on materials for the Joan of Arc character, I created a node-based material for the metal armour called BlurredTgtSpec. Now, I’m not sure how this happened but a lot of the objects that make the armour got different copies of this as BlurredTgtSpec.000, BlurredTgtSpec.001, … etc. So I selected each one in turn and assigned BlurredTgtSpec as the material, saved my work and restarted blender. This should have gotten rid of the duplicates but for some reason their hanging around. In the Outliner, these don’t seem to be assigned to anything and I can’t figure out how to get rid of them. Anyone have any ideas of how to get rid of them?

Screenshot of Outliner:


Anybody? You can grab the blend file here.

I only see one BlurredTgtSpec with 13 mesh items using it, no stray copies of it.

Um, i’m not seeing anything like that either. Though I did somehow manage to load the file up in 242, heh.

If you still have the extra materials, first check the popup in the link&materials box for any random mesh item, which should list all linkable materials in the file. If they’re there and not in use, they should have either an F or an O next to them. The O means it won’t be saved when you save.

You can also check the datablock directory, which is shift-f4. Go up from wherever it starts you and into materials/ . . . you can get a report on “F” status (and change it if you right-select and hit F) and number of users per material.

If you didn’t know, having the F is what makes it stick around even when it’s not attached, for stuff you want to reuse (I keep a few materials that are just nice for seeing the shape your working with in edit mode) – I got myself serously befuddled until I figured that out . . .

Oops. That blend file was for 2.43 release candidates and was a copy I made for rendering. Anyway, the copy I have for 2.42a has this problem. The datablock directory doesn’t show an F or an O (and I cannot delete the material from there). Neither does the Link and Properties panel. The Outliner doesn’t list these either. Anyhow, I didn’t realise that it wasn’t a problem in 2.43, so I won’t worry as I’ll be moving to that version anyway.

Thanks guys.

Hey guys… sorry to bump this thread but I had the same problem even in the released 2.43. I finally figured out the problem. It seems that if you have a node based shader that uses other shaders (for instance I used different shaders for diffuse and specular shading), all these don’t get removed even though the node setup is no longer used. So for each BlurredTgtSpec.* that was not being deleted, I went to the Node editor, deleted all nodes in there first. Then turn off the Nodes button for this material and remove it from any mesh it is assigned. After a save and reload, the “rogue” materials were gone.