Rotating an object's axes and texture axes


(LukeW) #1

Hi,
I’ve got a hold of a pixar-style eyeball from BlenderChar and I’ve duplicated it and I’ve tried making them both track to an empty. As soon as I do that their axes flip around - I initially had the eyes facing horizontally with the empty on the same horizontal plane. Then when I do the “track to”, the eyes face the ground. After the “track to”, the y axes of the eyeballs point directly at the empty and the z axes point to the sky. Initially the y axis pointed downwards and the z axis pointed away from the camera into the screen.
I can make the eye stop facing the ground and face the horizontal plane instead, so that the tracking works perfectly… I did this by going into editing mode, selecting all the vertices and and rotating them. The object’s axes stayed the same, and so did the texture space (TexSpace) box.
I might be able to get it to work through trial and error adjusting the size and offset of the texture in the material editor but it would be nice if there was a way of just grabbing the texture space box and rotating it… or rotating the object’s axes and having the texture space box automatically update or if it didn’t flip weirdly in the first place when I made the eyes track the object.
http://members.ozemail.com.au/~wenke/2eyesb.blend
Here is where you can download it… I’ve only got the left eye tracking the empty “focal point”… the right eye is how it was originally. As you can see, the y axis of the left eye tracks the empty and the eye is facing the ground.


(ilac) #2

In the untouched eye:

  1. Press Ctrl-T to track the eye to the empty
  2. then press ‘N’ and set the ‘X rotation’ of the eye to 90 instead of -90

:wink:


(LukeW) #3

Hi ilac,
When I press ALT-T, it brings up two options - “Clear Track” and “…and keep transform”. I’ve tried lots of different combinations of things but it doesn’t work. Basically after I’ve made a sphere “track to” the empty (using the constraints) I can’t get it to rotate properly - it just seems to squash a bit - it doesn’t rotate - even if I press “R” and change to the different views. :frowning:


(theeth) #4

You should always clear the rotation (Alt-R) before the tracking.

After that, you can adjust the Track and Up axis in the Animation Buttons window (F7).

Martin


(ilac) #5

Bummer! My mistake. I meant ctrl+T.

Ok here we go again:

I didn’t realise you were using the ‘track to’ constraint (my method was the older way of doing Tracking, though the same solution as below still applies)

The solution to your problem is in Theeths reply. In your case you have to set the Track to -Z and Up to X (UpX) in the animation buttons.
You can clear the rotation before or after having applied the tracking, so don’t worry if you forget to do it before!

Does it work this time? :smiley:


(LukeW) #6

Thanks, I got it now… I can actually do it without clearing or adjusting the rotation… I only needed to go into the animation buttons…


(ilac) #7

Great! :smiley:

You didn’t need to clear rotation this time because it was only rotated by a 90 deg and therefore still aligned to an axis. You’ll notice the importance of clearing rotation when you try to track an object which isn’t rotated to degrees perfectly divisable by 90s! :wink: