Rotating never gets good


(Detritus) #1

Hi! I have this objects I want to rotate 360 degrees in top view, but when I do so it also rotates in the other axises, not just around the nort-suothpole axis. Why? And how can I make it stop?

Antoher problem is that the objects change places (it´s a lot of curves) during the rotating, so it get´s all mixed up. For example the front curve slides through the back-curve while rotating. What can I do to make this go away? PLEASE HELP!


(haunt_house) #2

Do you rotate for animation? if yes, you can do it by editing the ipo curve. Anyway, try nkey ( ipo or not) and set the value there.

If you have several curves, parent them to an empty and rotate it instead:

HH


(theeth) #3

Since Blender use Euler’s interpolation for rotations, you’d have a better result if you split the 360 rotation (you’d have to do the same for 90, 180 or 270) into sub 90 step. Like six 60 rotation in your case would be good.

Martin


(Detritus) #4

Thanks! Editing the IPO-curves works!


(VelikM) #5

Joining the objects so they all share the same rotation point sometimes makes it easier, also setting the rotation with the N-key makes it easier to control the axis of and the deg of rotation, reduces the amount of curve editing needed.