Rotation applies another from seted up transform orientation

I have an issue, on a few of my models in scene. When i apply rotation to object, it rotate in “view orientation”, but my settings stay in “global orientation”, does there somthing realy simple I`m missing out, or is that just a weird bug? Its only happens with rotation.

I guess what problem is when i rotate object in one certain view (right view for this example) its not rotating properly on the same axis. After applying all transforms its still have the same issue

P.S. To kinda “apply” this delta rotation you should first apply usial rotation (the object might fligh away and rotate) and then clear out delta transforms in “object properties and under Transform -> Delta Transform”.

Unconstrained transforms always start in view orientation.

1 Like

Oh thx, you right about that, but there is still a problem. Its hard for me to explain, so here is video.
I can guess what problem is when i rotate object in one certain view (right view for this example) its not rotating properly on the same axis. After applying all transforms its still have the same issue

Hmm… are there any modifiers/constraints on that object?

Sadly, but no.

Perhaps you could upload the .blend with just that bow? Textures etc. don’t matter. I’d really like to take a closer look.

Shure
Simon`s_wierd_hat_with_bow.blend (324.6 KB)

Hat also rotating wierd but in other (front) view

Ah, there’s a delta rotation on that object (I guess you applied rotation to delta by accident instead of just applying rotation). Open the object properties and under Transform -> Delta Transform and clear out the rotation. On the hat too :slight_smile:

1 Like

Oh, thanks a lot :smiley:
It might have happend after an animation or export from 3DCoat :slight_smile:

1 Like