Rotation in edit mode results in unwanted bone roll

When I rotate an inclined bone around Z in pose mode => no bone roll.
When I rotate the same bone in edit mode => unwanted bone roll.

How can I prevent this from happening in bone edit mode?


One thing you could do is rotate it in pose mode, then ctrl-a apply selected to rest pose.

I agree that the roll calculations in edit mode aren’t really great; I don’t think it handles them as an actual axis in edit mode, but as a bone variable, which makes them weird. Generally, I get my tail pointed where I’m sure that I want it before setting roll, and then use ctrl-n to set roll (often, to a cursor that has been snapped to some other bone head/tail).

1 Like

On this example it works, but I just tried that on another setup and the bones changed pose.
Obviously it can only be used before one sets any constraints.
Unfortunately Blender lacks consistency between its functions.

It’s a useful workaround nevertheless, thanks for the info!

The precise way that changing the rest pose affects the constrained pose is going to depend on your constraints. You may find it useful to temporarily disable constraints when using apply as rest pose. Some constraints may still require recalibration (stretch-to is a particular headache.) Better, you’re using a rig where its rest pose is identical to its constrained pose. If you’re editing a rig, you’d best have a good understanding of the way that rig functions before trying to edit it. (One of the reasons I recommend anybody trying to edit rigs be using rigs they made themselves, rather than, say, a Rigify rig.)

Thanks for the advise, I remember a few things of what you said, from the era before my 7-year break from Blender. This time, I’m trying to set things on good or “safe” foundations as much as possible, like creating a rig with identical rest pose to constrained pose like you said.