Rotation not working, only preview

Hi! I just started using Blender and probably accidentally clicked something.

I can only rotate the object using the transformation panel. If I use the rotation gimbal it only shows how far I am rotating it but it doesn’t execute the rotation. (See picture). Hopefully, someone knows what I did wrong… you’d be a lifesaver. Thanks!

Heya, the red line going across is showing you are rotating around the X axis, try pressing Y to rotate around Y (should show a green line).
It’s guesswork, but the wheel might have locked rotation axis since it would make sense for it to only rotate around the axle.

Heyy! Yes that makes sense, I tried it already but even when I try to rotate a cube it shows the same :frowning:

You seem to have proportional editing switched on. (press O to toggle, it’s the little blue circle int the top bar) Maybe that’s the culprit.

Hmmm also doesn’t seem to change anything unfortunately.

Checked my answer, turns out locked axis does not show on the rotation gymbal, so it wasn’t that.

Is the mesh you are trying to rotate the white ring ? or the wheel assembly ? Can look at it more if you upload a file showing the problem.

Well haha, actually just rotate anything. Nothing in the file is able to rotate, if I open a new one it does work. I can’t upload the file because I am a new user…

there is an option that restricts the transformation to only the pivot
image
shortcut is ctrl + .
tried that one?

Yep, again not changing anything. Thanks for all the input though! My setting is currently: Options -> Transform -> Locations.

they should be all unchecked by default

1 Like

Aha!! That’s it thankyouuuu !

:slight_smile: haha, cool.
guess we’ve all been in that spot one time or another