Round edges of my mesh

Hi! I want to make the edges of this star round & soft. I tried bevel but it doesn’t work. Is it a problem with the mesh? Does anyone know how to fix this? Thanks


  1. Extract only the edges.
  2. After converting to Curve, use the Curve option to create a shape.

※ The desired shape is impossible without deformation.
Deformation occurs because we need space to create edges.

fsafas.blend (1.0 MB)

6 Likes

You can get there easily with poly modeling aswell . (The bevel wont work well there directly cause there’s no space for that bevel method at the spikes to give the new faces some space without the borders crossing each other.)

  • Make your flat sides ngons, extrude them a bit and scale them down
  • On the sides you add two edge loops
  • Then you can dissolve the org edges to chamfer the corners.

If you want the chamfer smooth then bevel the new sides loops

2 Likes

Thanks a lot!! :white_heart:

Thank you :pray:

1 Like

What shortcut did you use to select all the edges of one side?

You mean the selection at the beginning? Thats Ring Select, have a look here (https://docs.blender.org/manual/en/latest/modeling/meshes/selecting/loops.html; Ctrl+Alt+LMB) . But that works on quads, so dissolve the diagonal edges that make them triangles in your case first if you want to try it out.

1 Like

Another question :grin: I used tris to quads, but for some reason it only works on one side (even tho I selected all and played with the angle settings.) Can’t figure out why this doesn’t work :confused:

You mean it the tris to quads doesnt work as nice on both sides? Well I didnt read into its code, but the problem originates from the processing order of the data and the way the algorithm is programmed. In short there are several ways to solve a problem and especially with so called greedy algorithms a decision is based on a local criteria or heuristic to guarantee a performant behaviour. Thats the reson behind, but just take it as is, make a smaller selection or dissolve a couple edges by hand and see if triggering it on the rest leads to a better result. Or in such a small case as yours simply shift-select them manually and dissolve them yourself.

Figured it out, thank you so much for all your support :pray:

1 Like