RTX 3060, no compatible gpu device found

In preferences, system, cuda, Blender sees my new RTX 3060. But in the opencl tab it’s showing the "no compatible gpu devices found for path tracing, cycles will render on the cpu.

I am on Mint 20, with 470.63 Nvidia driver

Where do I look?

Hi.
Did you mean OptiX tab?

Both CUDA and Optix see the GPU, Opencl tab does not.

It is correct, you do not worry about it. OpenCL is disabled by default for nVidia cards, OpenCL runs slower than CUDA and much slower than OptiX. You should use OptiX with RTX card.

By the way, good to know that you were able to acquire a new GPU (I remember that you had problems with your old GPU)

Edit:
If you want to use OpenCL only for testing purposes, there is an environment variable to start Blender and enable OpenCL on nvidia cards, but I can’t remember it right now.

Ok , thanjs, but when i change from cpu to gpu compute, gpu is selected but greyed out. And it renders slow like cpu.

In which version of Blender do you have this problem?
Does it also happen with Blender 3.0 Alpha?
I think I remember other users were having similar problem with RTX cards.

installing 3.0 alpha…

OK, It’s all working with Blender 3.0. Thank you. :sunglasses:

And very fast.

Great!

Cycles is faster in Blender 3.0 but it has had a great refactor and may still have some problems and be somewhat incompatible with some of your old files. If you notice any problems, you try Blender 2.93

1 Like