Running blender on Ubuntu Dapper Drake


I’m experiencing serious troubles to fins a solution for the OpenGL issues with a nVidia graphic card in Ubuntu Dapper Drake. A RIVA TNT2/TNT2 Pro with 32 MB Memory, produced-sold by Canopus.
Running Blender from terminal, shows as follows:

Using Python version 2.4
Xlib: extension “GLX” missing on display “:0.0”.
ERROR: Unable to open Blender window

During the pasts 36 hours aprox. I’m trying to solve trough solutions finded browsing the web. Solutions suggested, while similar, appears contradictory and inconsistent, when by the “try and if not try other” method.

I’m a newbye in linux but not a complete noob, so i’ve tried something more advanced than simply reinstall the system or reswitch to windows, i hope u understand. But now i’m a little frustrated. I will research still more, but if somebody has the same problem, at least i will not feel so lonely ;-).

If i have the time, i will post some links and documentation.

Hi, glaurung.

Well… I´ve had same problems on running Blender some time ago.

I really don´t want to make you more confuse, but I know 2 possible solutions for it:

  • the first, which is easier, works ok, but is some kind of workaround, not the most correct and complete solution, since it will not get all your card can offer.

  • the second, that demands you a bit more effort, but I believe its the most correct one, since it should avoid problems in other situations that your system could require 3D acceleration.

Solution #1:Apparently your card´s 3D acceleration is not active. So you can downloaded the “static” version of Blender for Linux and it should work fine.
From “Static Linux version is for systems without HW OpenGL.”.
You can download it here:
Solution #2:Download and install the binary NVidia drivers. Probably the less painful way to do it is from the Automatix installer (

With the 3D acceleration enabled, Blender should run smoothly on your system.
Hope it helps.


Hey Virgilio,

thanks for responses,

i’ve tried Automatix yet, and some other similar solutions, like a “envy” called script that is supposed to solve dependencies and so. The problem is that when i change in the xorg.conf file the driver from “nv” to “nvidia”, computer hangs while starting xwindow on reboot. Hangs in three ways, no ubuntu drums heard in any of these:

1- sometimes, simply a black screen
2- other times, a blank and uncentered window smaller than the crt screen, remembering a misconfiguration of a graphic card in microsoft windows.

(((3- other the system alerts about misconfiguration of the card, stops gdm and drives you to a standard non root login command line. This one i think appears as a response of the system on my various essay to make things work, activating strange options in the dpkg-reconfigure xserver-xorg and so)))

As i’ve said, i have done a notable amount of research, and as usual the problem appears as only of my graphic card. But i fight against this idea of no solution.

Now i’m running an spare ATI card and also don’t works. There are Mesa drivers, i don’t know almost anything about, but him are here, showing crazy incomps. between himselves… I don’t know if needed for blender but are used by audacity and others if i should trust Synaptic… There are also a and nvidia-drv.o in a usr/…/modules/drivers dir… there are a blenderuser completely surprised of difficulty of things… and more, almost anybody talks Dapper language, it seems… AARGGGH!!!

yet another day without solutions and more questions… but i’m not here to complain, i know. I will try to be more constructive.
to start, some links you can find useful…

Help from ubuntu, more or less “direct”

Envy script to install nvidia drivers:

try to set it up with the binary nvidia driver available from

take a look to /var/log/Xorg.0.log
maybe there is a clue of whats happening.

Are you sure the nvidia module is loading?
to be sure do:
“lsmod | grep nvidia”

and you should view something like
“nvidia 4717620 22”




on lsmod | grep nvidia i’m viewing this:

nvidia 3926540 0
agpgart 34888 2 nvidia,intel_agp

this mean nvidia module is loaded, right? but meanwhile i’m starting the system with the nv driver, because with the nvidia one i can’t start the desktop interface.

However, Xorg.0.log shows also this line:
(EE) Failed to initialize GLX extension (NVIDIA X driver not found)
and this one below: (i don’t know if it’s related to…)
error opening security policy file /etc/X11/xserver/SecurityPolicy

and my system is a Intel PIV on a Asus motherboard with 1024 RAM, without any special extra devices like Secure Digital or Memory stick readers and so. Only a IEEE1394 card which (after loading modules and this stuff) works right while capturing video. Only for information…

thanks people :slight_smile: i’m not feeling alone

edit: i’ve seen some apparent uncorrespondency in “build” and “current” OS, in xorg.0.log, so i post this file here. If it helps somebody to diagnose the problem…:

Did you change in /etc/X11/xorg.conf

Section “Device”
Driver “nv”
EndSection to

Section “Device”
Driver “nvidia”

I think the problem is that you are still loading the nv driver and that prevents the nvidia driver to load correctly.
In your log file:

(II) LoadModule: “nv”
(II) Loading /usr/lib/xorg/modules/drivers/
(II) Module nv: vendor=“X.Org Foundation”
compiled for 7.0.0, module version = 1.0.1
Module class: X.Org Video Driver
ABI class: X.Org Video Driver, version 0.8

try searching your /etc/X11/xorg.conf file to see if you are loading the nv module.

in this link they explain how to configure by hand the xorg.conf file.

hope this helps



thanks for suggestions and specially vico for the link: it seems to be a confident information, not only a page of a “touch here and here and it should work”… i will test his suggestions.

In the other hand, i suspect (:-)) you are misinterpreting the xorg.0.log: here appears the nv driver as the loaded one because this is the driver that at the moment (when i saved&uploaded the file) i should use to start xserver. I think the nv is not loaded when i change nv to nvidia in xorg.conf file and reboot. Simply, the systems tries to load nvidia driver but i think a misconfgiuration don’t lets start. Where the misconfiguration, this is the question :).
But i can be wrong, of course.

I hope good news soon.

Off topic but, can someone explain how to enlarge the session time? This is a shit, to “speak in silver”, as said in spanish… just edited to add links and the whole added is erased after an error message.

Not tested, how to make symbolic links to solve troubles with paths to the drivers:

Spanish page, useful to “know how”

French page, similar to other but well referenced: