Runtime Error

Good day ladies and gentlemen!

When I attempt to run a runtime of my game I get a Visual C++ Runtime Library Error. I have attempted to update my C++ Runtime Library but it appears that I already have got the latest version. When I save my runtime I also have Blender include DLL’s.

I have been looking around for a solution to this problem but have been unable to find one. I would very much appreciate any suggestions on how to solve this problem.

Have a nice day!

Not saying this will help you get a solution but it would be useful to post the details of the error, the machine, the software your running. In my own personal opinion it can also be useful to test it out in a virtualbox environment (if your machine supports it) with a clean install of software.


Above is a screenshot of the error I get when I try to launch my runtime. After I click OK it simply crashes.

I am using Win 7 64-bit as well as Blender 2.60.0.

As for hardware I’ve got an Intel i7 2600K and a Nvidia GeForce GTX 590.

Yep, really not much in the way of clues there unfortunately. Does this happen with just your game or even just a default scene in the blender player?


I managed to get a screenshot of the terminal when launching the runtime for the default cube scene. I still get the same error with the default scene.

What version blender?
It’s using python 2!!
If it’s blender 2.5+ series it should be using python 3.
Try deleting the python libraries and re-copying them from the blender python folder.

Thank you, sdfgeoff, copying the Python libraries from the Blender Python folder did indeed solve the problem. It worked perfectly on the default scene but when I tried it on my game it did indeed not crash but once it had loaded it only displayed a gray screen, just like the background in the default scene. I have checked the relations for my camera and made sure that it is on the correct layer but that doesn’t seem to be the problem.

I have got both Python 2.6 and 3.1 installed on my computer, would it be possible to have Blender use the correct libraries right away without uninstalling Python 2.6? I have still got some old programs that I wrote in 2.6 that I might want to use again.

Actually it should not mess around with python Versions. I have the setup, Python 2.6,2.7, 3.1, 3.2 ?? … with a lot of libs …
blender should find the correct library. Would be interesting to know, what really happens in behind if an error like this occurs.
I agree, re-copy the folder; i would even reinstall blender .

The “grey screen” sounds like you may not have materials on all your objects.
In the external game engine, all objects, to display, must have materials.
That or it may have lost the UV textures

First I’d like to apologize for not responding for several weeks. I have been quite busy and haven’t had time to sit down to work on my project.

Some of my objects are using UV textures while some of them only use some rather simple materials. I am using GLSL shading, could this cause any problems? I have got my camera parented to the object the player controls in the game, do I need to set up any logic for the camera to properly follow my object i the runtime? Currently it looks like the might camera spawn in a completely random location as I cannot see anything except a grey background.

if you use glsl, you need at least one lamp in your scene in order to see anything, except you are using shadeless materials. i recommend you to use a hemi light for testing purposes as it creates a very regular and smooth lighting.

I am currently using a sun lamp to light my scene and I have got a few point lamps parented to the player’s ship (I’m making a simple space game).

Care to throw us a blend. It think we’re out of ideas.