Runtime Game isn't working

I’ve used 2.6 to create a basic game, and I have all of the .dll files and everything in the same folder as my runtime game. I also fixed the double lib folder issue (so there was only one), but I get this error message anyway:


Thanks for your help!

Export as runtime works fine for me. I’m using Blender 2.60a on a Windows x64 machine.

Does the folder of your game look like this? Do you have all of these dll files inside?


You mentioned that you deleted the extra unnecessary lib folder, but just to make sure the files where all the python files are stored it is (insert folder name here)\2.60\python\lib ?

Here’s another image:


And yes, that is the file directory I have. I’m also running on Windows 7 64-bit, if that helps at all.

Could you also get a screenshot of the console window?


How’s this?

Okay, that usually means Python isn’t being bundled correctly.

Do I need to re-install it? Sorry; I don’t know much about Python :o

is an known issue…
go into your game folder - 2.60/python/lib/lib/*
move all files in one directory above -> 2.60/python/lib/*

i´m going to check if a bug is open !
Tobi

i opened a bug in the BGE Bugtracker - http://projects.blender.org/tracker/index.php?func=detail&aid=29095&group_id=9&atid=306

cheers
Tobi

Thanks, realtronix, but I already did that, and it’s still not working :frowning:

Does anyone know how I can fix this?

Hey, you are using the latest version of Blender, right? If not, try one from GraphicAll. Maybe it’s looking for 2.59/python/lib, and you have 2.6/python/lib. Just a thought.

I can’t. I animated a few still objects, and 2.59 won’t let the ‘Action’ logic brick work unless the objects have armatures. But from now on, I’ll use 2.59 to create games, because it works!!! Thank you so much for helping with that :smiley:

If you know of a workaround for the animation part, though, could you tell me? Thanks again!

Are you sure? The Action brick replaces the F-Curve and Action bricks from pre-2.6. In other words, you have to specify an animation to use animations in 2.6.

I know that, and I did specify the animation to use in 2.6. But when I opened the game in 2.59 to export as a runtime, that switched to the ‘Action’ brick, and there was nothing there - it said it only worked with armatures.

I think that it was somewhere between 2.5 and 2.6 that the F-Curve brick got changed to the Action brick. I thought it was earlier than 2.59, but maybe not. The problem is that you can’t export a runtime with 2.6, correct?

I think that maybe there’s something wrong with the bundled Python in your download - it looks like it’s having problems with the Python distro that it finds, which is odd. Try making a simple runtime in 2.6 without any logic bricks or anything special in it. Put it in the Blender directory if you don’t want to copy everything. If it fails, then try a newer build off of GraphicAll. If it doesn’t try exporting your game to the Blender Folder.

EDIT: By the way, are you using Python? Can’t hurt to ask.

Yes, I am using Python. Thanks for the suggestions! I’ll try some of them :yes: