Same folder is not Same folder?

Hi, how to solve this?

when i turn on the BGE, import a script ( that is in the same folder,
then i change the scene(logic brick > start new game > second.blend)

now i have the complet same script setup that also imports that very same script (

but this time, it says “import error: no module named core”
but that is horse shit, i have put all 3 things in that same folder.

When i put that core to the sys.path listed folders(any of them, expect the listed CURRENT one), it works.

pls help >.<

try do print out the current blend path with:


when starting the game engine and after loading the blend.

Maybe there is a difference.

i have done like you wished, but unlucky again
the print only showed a empty line in the console.

mysterious :frowning:

Run the following both times:

import os

It should give a bit more insight.

Hi, i was able to solve the problem, by installing blender and python properly.
I used the Zip from and mb that was the cause of problems.

Thx Monster and Moguri for your help as this is solved now.

But here come the next problem:
In order to organize my project, i was about to split alot of things and to work with links.
So i have a container file that holds information about materials and 3 other blends that use those materials. After i go in the first of any of those 3, then start the BGE and change to another while in BGE, any of the informations is gone, leaving things gray…
I will update this post with the files.


greets Equal

I’m not sure if you can split the game in that way. Usually the linked .blends contain complete objects (incl. meshs, materials, IPOs and poses).

But I could be wrong as I never tried to link materials from other files.

i have discarded this kind of organization, and will only truly link full objects.

nontheless Thx and greets equal