Sapling issue

Okay, so I have just started experimenting with the Sapling Addon in Blender and I already have an issue. For some unknown reason, the Shape button is greyed out on the Options menu. And I got no idea why, I really just popped one in and bam. It’s greyed out.


Change the “Settings” from the default “Geometry” to “Branch Splitting”
http://i.imgur.com/tStmtEn.jpg

By default the “Levels” is set to 2, change it to at least 3 or more , that’s the requirement for the Shape button to actually work
http://i.imgur.com/1eZDjMW.jpg

Change the “Settings” back to “Geometry”, you will see that now the Shape drop down menu is not grayed anymore and works as it should.

Thank you!!