Sapphire Radeo X1600 Pro ... Problem

I bought a Sapphire Radeo X1600 Pro. But I have serius problems. Menus are not working good. I turn the International fonts on but there still slow. When I use a background image then Blender gets really slow. I believe tha I get around 5 fps. And the Image it’s too small for example 265*75 .

The stupid of out me is that I knew that there is a problem with Ati cards but … I heard before some years that this was in the plans to be corected. Also I heard that OpenGL drivers of Ati tha get advanced. But…

Is there a way to fix this problem… Most of all I need the backfround problem cause without a template I cannot model as I used to.

I forgot to say that I am under WinXP

I’m using ati also, and I have never had any problems… and that is both with a x600 and a x1800xt… have you tried using the omega driver…? maybe that could help, but I am not sure…

i have the x550 and it runs good. my suggestion would be just to return it and get a new one, see if the problem was the card or something else.

I had problems with my X800 and X850xt until I turned off the global slider to “Best Appearance” and set it to “Best Performance”. Don’t know if that helps you.

I run Sapphire Radeon x1600 Pro also, and I have absolutely no issues with it, or Blender. I doubt the amount of vram would have much to do with it, but I have 512 for reference, if that could be a cause.
My settings are generally default, except for “High Quality” instead of the middleground for 3d.
Make sure you have the absolutely latest version of Catalyst (I use Gameshadow, it keeps me up to date on all the latest drivers and such, you may want to give it a runthrough, even if you don’t game. Highly useful tool).

I get excellent render times and such on an otherwise decent computer, nothing spectacular. 1 gb of ram, 2.6 ghz Hyperthreading P4.

I advise checking drivers, and making sure you don’t have a random setting changed to incredible quality, possibly slowing it?

Hope you figure out the solution,


Thanks all.
But the problem remains. It is not a problem of a sqr soze texture e.g. 512*512 it’s something else that I cannot find. Also one strainge thing is that if I use a textured template there is no slowdown. I will continue with the textured planes. I just need sometime to get used to them.

Hey haramanai, have you installed the latest driver from

Also, try using a different version of the opengl driver. Ask one of the ati users here to upload their atiglxx.dll file and put it under your blender directory where the blender executable file is.

ANOHER soluiton: find a nVidia opengl driver (called NVOGLNT.DLL ) and renamed it to atiglxx.dll and put it in teh same place as mentioned above. This will essentially disable all hardware acceleration, the overall blender interface will feel slower, but it should fix the ati bug.