Save executable not working? What am I missing....

So this isn’t a big deal AT ALL, just a curiosity really: My kids are over and my oldest made a little peg solitaire game with his Lego’s and I decided to make that game in the BGE. Nothing complex, no scripting and super basic just as a test I guess. I got it all set up with logic bricks (except the rasterizer to show the mouse cursor). It works fine within Blender, but when I save a runtime, almost none of the logic seems to work correctly?

Solitare.blend (777 KB)

Simple rules/directions: The objective is to clear all the pegs from the board except the last one. Pegs are removed by jumping them with another peg horizontally or vertically (not diagonally). The player moves a peg by putting the cursor over the peg they want to move, then clicking one of the arrow keys on the keyboard in the direction they want to move the peg. Clicking on the white sphere to the left resets the board.

In BGE, playing the game and resetting the board works fine. In a saved executable, some pegs won’t jump when they’re supposed to and will jump when they shouldn’t be able to. It just acts really weird so I was curious if anybody here could figure out what’s going on. Is my logic somehow broken, or is it exporting the runtime incorrectly?


If it works well in Blender itself, then you shouldn’t have to jump through any hoops to get it working in the player (as it uses more or less the same code as the game in the viewport). If it doesn’t, well, you can try your luck at reporting it to the tracker and ‘maybe’ a developer will fix it after a while.

Chalk up one more reason why the BGE is a decaying engine I guess.

What version are you using? Also have you tried running the Standalone player in blender to see if the same thing happens? Standalone player is in the render panel under Embedded player.

Actually yes this is a good idea, there have been a couple versions of blender with broken export (i think 2.69 was one of them). Either way try use another version of blender.

This is unrelated to the problem, like the other 20 times you have mentioned exactly the same thing “Why BGE is terrible” and “report it as a bug, but i doubt anyone will fix it” in various support threads.

You have made your point, we get it, BGE is in a bad state. There is no need to flog a dead horse, we already know, so can you please stop posting meaningless comments that don’t help the person with the problem.


I compiled this on a recent 2.72 build and they both act the same- same moves work, same movements. Have you tried the most recent offical build?

Fun game BTW.

My build is 2.72 560dd93

I think I did go a bit overboard in these cases, and I apologize for that, my mind has been somewhat muddled by the onset of a bad cold and it was hard to think straight.

Though if it is true that export breaks and gets better depending on the version, this makes things tricky as you can’t cherry-pick the version with the lowest number of serious bugs and regressions to export your project with (I believe 2.69 for instance was the best version of the BGE in terms of new features and things working since 2.49).

I have been moving my personal game project over to 2.72b from 2.69 and did a quick little standalone test. I am seeing some issues with what seems to be “visibility” logic bricks. However when using the embedded player in 2.72b, I have no problems. I haven’t actually saved a runtime though.