scale and rotation to OBdata

I have done this to my meshes but now i found out it should be done for an armature
I already have my actions set to my armature but when i applied scale and rot to my armature the objects move oddly. My question is, now that i have an armature already moving well should i redo and apply scale rot to armature then do my actions or should i just ignore it considering my armatures are moving well? I guess i am also asking what the importance of scale rot

digiman

Unparent your mesh from the armature. Apply scale and rotation to obdata on the armature. Reparent the armature to the mesh (as armature) using Ctrl+P, and don’t create new groups. The armature will automatically use the vertex groups and weight painting on the mesh already, and all of your actions should still work fine. (Be careful about applying rotation. You may mess up some of your rotation based actions. If so, undo the process and just apply scale, since it is the more important one as far as potential problems cropping up.)

Applying scale and rotation to obdata is important when you are dealing with object parenting relationships and added objects. Historically, added objects in the BGE inherit the scale and rotation factors of the object which is adding them. I’m not sure if this is considered a bug or a feature, but I think it makes sense as it is.

I’m sorry, but this doesn’t help me. Unparenting the mesh from the armature and then apply rot/scale to obdata still makes the armature move in a weird way…

I tried it a few times and it worked okay other times seemed to work worse. If you can’t get it to work I think you should start a new rig it’s a pain but worth it in the long run. If your objects are moving good now maybe just leave them alone

digiman

Is it a bug? Isn’t there someone who knows about this part of Blender???/ I really don’t want to create a new rig unless It’s my last resort.

Like Blendenzo says try it just applying scale forget about rotation That might helpIf it does not make a new rig. I had to remake some models because i forgot scale rotation. only just found out about scale and rotation to an armature. It might be a bug i don’t know. I tried to make realtime shadows but it did not work I found out after several times trying that shadows only work for opaque or clip alpha but if you have any alpha on your model, realtime shadows don’t work. Design flaw or bug? who knows

digiman

Whether a bug or design flaw, I think it is a considerably heinous one. If you need to export something to another program with a different coordinate system, it can create huge pains when having to manually reorient your model. So if you plan on doing any considerable animation work using actions, you better be bloody sure your model is oriented in the right direction, or kiss your animations goodbye.

Maybe you could post a screenshot of the weirdly moving armature to help us get a better idea of what’s wrong.

Sure this is before applying Scale Rotation to Obdata tha animation is that of a sprint…I tried to only apply scale, but is seems that scale is the culprit


And this is apply applying ScalRot to Obdata:


Hope this helps

bumpoe