Scale marking on glass beaker?

hi everyone,
i have modeled a normal glass beaker and i have applied glass texture to it. For scale marking on outer surface of the glass i used UV maping and i applied an transparent image but i doesnt work some how i can only see the outline and nothing else here is the render image and blend file as well…


beaker 03.blend (223 KB)

the way i understand it a uv map largely overrides the texture given by the material it also makes the image easier to place
With ships, it’s sometimes very important to add decals. The way most modelers add them is ether through mesh modeling, which is very tedious, or textures which can be very hard to align when you have a really complex mesh. This tutorial hopes to tackle that problem and make it very simple to align your decal.
*This tutorial is based entirely on the Theeth CJ Decal tutorial.
For this tutorial you’ll need an object, I suggest you use a ship of some sort, but if you can really use any object. Add a new material to the ship, then a new texture, choose image and the select any picture you want, then select ‘Clip’.
Now add an Empty, place it where you want the decal to appear on the ship, the Z axis should be perpendicular to the surface, if you rotate or resize the empty, it’s going to effect the decal.
With the ship selected, go to the materials window, you should see a tab to the right called ‘Map Input’, under that you’ll find a button called ‘Object’, select it and then in the space type the name of the empty (which should be ‘Empty’).
Well, that’s it. It’s very simple, but very effective, if you resize, move or rotate the empty, the decal should do the same.

i have got this to work in the past but i had problems with repeatability maybe someone else could shed some light???
hopethis helps

For decaling there is this video tutorial at Blendernewbies


here is the render image it will give you guys some idea what i am trying to say…
On any beaker or any glass measuring instrument there is scale marking on it.
what i have done that i took an transparent image(.png) of scale marking i made in photoshop and i used it in UV maping on outer surface of the glass beaker…in texture i can clearly see the image on my model in 3D view port but the same when i render i am not getting the same result instead of that i just gets the outline of marking…


i think you can make a PNG from blender no GIMP

so make the mesage + other objects you need over a white plane
then put the camera over it and ave it as a PNG

anything white i think can be translated to tranps material for texture image ?
anybody ahs tried this before ?


In the Map To palette, select Neg. You can also increase the emit value to get a brighter white colour.


hey thanks…hey can u send me blend file back please…that’s exactly what i want…thanks once again…

beaker 03a.blend (80.4 KB)


intersting way to do it with UV mapping

but you can also do this with simple mapping is it ?

is the Texface automatically or manually in material panel ?

and can you upload the image
would like to compare it to a simple blend image save as PNG

have you ever treid to make one a PNG with blender ?



I’ve had a play with your file too (attached). I used the same texture twice with different settings, one to change the colour, the other to change the alpha. I also had a bit of fun and set up a product shot of your beaker filled with a nice green liquid :eyebrowlift:


hi everyone
hey its look good with liquid and thanks for the file so i can have look…

Richard i didnt get how you can reduce file so low i mean from 223 to just 88 kb less than 50 %…i mean how?


Can someone please explain why the texture can be seen in the 3D viewport when it is set to Solid display?

cause it’s a UV map

if you go into uv editor you’ll see it there!

but would still try it with ordinary mapping and see waht happen

any advantages for UV or easier in ordianry mapping?

ok did a test with yafaray

but i don’t see teh UV map there?
see pic

is there something to be done to transfert theses UV map in yafaray?


Sorry, I am still missing something here. When I apply a texture to a material on an object using UV mapping, I only see the texture on the object when the 3D viewport is set to Textured. When set to Solid, I don’t see the texture on the object.

In this beaker blend file, the texture is visible in the Solid view. If I append the beaker object from this file to my default setup, I don’t see the texture in Solid mode either. So there must be some difference in the view options between the beaker blend file and my default, but I can’t find it.

well that’s the idea you can see UV texture only in texture mode not solide mode!

but don’t know what it will be in 2.5

so may be not that important anyway for the time being

as long as it render well that’s ok i guess


OK. I found the difference.

To display textures in Solid view:

View -> View Properties -> Solid Tex.

i like the look of the beaker model i like your work, very tidy

hi hey can you tell me what changes you made so that the file reduced to 86kb from 223kb, its more than 50% ?

When you save the blend make sure ‘Compress File’ is selected under the File menu.


hi everyone,
i got it how to do scale marking now…
but new problem is this, i used same texture and material settings what Richard had done in a new file but i am not getting the same results i dont know why?
here is the render image, in this you can see it takes UV image as texture image but i have clearly selected UV in map input but still dont know whats happening…

beaker_03.blend (236 KB)