Scale "pixel art" video without blurring?

I’m using the Blender video editor to scale up some lossless pixel art footage from 320x240 to 1440x1080, and it’s introducing some blurring. I just want plain old nearest-neighbour scaling.

I know how to fix this if I’m rendering a 3D scene, I set the material’s texture “Interpolation” to “Closest”, and then in Eevee’s Render settings, I set Sampling to 1. Then the pixels stay sharp.

In Blender’s video editing mode, I can set the Samples to 1, but there’s no “texture” to speak of, where I can set the interpolation mode.

This is how it looks in Blender’s video editor (GOOD):
image

This is how it looks after Blender renders the video (BAD):

image

I went with “FFmpeg video”:
Video Codec: H.264
Output Quality: Lossless

Here’s a link to the lossless source video if anyone wants to try…

Which video format do you use?

I went with “FFmpeg video”:
Video Codec: H.264
Output Quality: Lossless

(updated original post)

Try zero filter size in Film settings

That didn’t make any difference :frowning:
I updated the first post with a link to the source video if anyone is keen on trying…

When your render looks blur, then change frame number and refresh preview. When preview looks sharp, then render in “Video Sequencer > Preview” window, “View > Sequence Render Image” or “Sequence Render Animation”.

1 Like

I can’t believe it… that actually worked! That is so weird…

Basically render from the “View” menu of the Preview window, not the Render tab…

Thank you so much!!