Scaling a circle extrusion in Edit Mode scales the entire mesh

For some reason, I was using Blender 2.61 to scale and extrude circles for a gun handle, but when I started on a different circle, which was its own object, it started to act differently.
I wanted to extrude a circle out and then extrude it again and scale that to 0 to make it look solid, but when I did that it stretched the previous extrusions so they met the new circle.
It’s like it’s scaling the entire circle, and it wasn’t doing that before.

Did I set some option or enable something accidentally? How do I get it back to the way it once was?


Do you have proportional editing enabled ? AN icon on the 3d view header or shortcut O

Ah, I figured it would be some kind of option I accidentally enabled with a button…
It’s back to the way it was now.