Scaling before exporting to STL

I use Blender to create models and export them in STL format to be used on Repetier Host (3D Print). But my workflow is not like on 2.79. In 2.8 I have to change the scale to 1000 before export (it’s a bit boring do it every time). If I do not do this the model is out of scale. Any workarounds?

Did you try messing with the actual scene scales ? See the scene pane

Yes. I use the default with 2.8. I tried to use the same standards that I use with 2.79, but the results are bad, too.

My 2.8 default:

Well ,change that accordingly in an empty scene and save it as a startup scene maybe? So that you do not have to fiddle with it.

Good idea. I will take a look at this tip. Thanks

Sure, it should help until this is fixed (if it was broken, not sure)

It would be really great if the 3D Print tools Add-In that ships with Blender (Since 2.6 ish I think) had an arbitrary scaling factor. If it’s 1 by default, but can be set to 1000 so it can output the STL file (Which is unit agnostic by design) in whatever scale is required.
I am also experiencing this as Blender thinks in terms of 1 “Unit” = 1 Meter and Cura thinks 1 “Unit” = 1mm.
I might see if my Python skills are up to suggesting a patch.

Solved. I changed the value of “Unit Scale” and the exportation works. In case of millimeters, I set it 0.001.

Hi! I am dealing with the same issue of unit incompatibility between my model and the printer house…quite annoying when they say, “it is in the wrong scale,” and I try to explain, “yours or mine? cause I created it in mm” anyways…I found your solution for tweaking the “scale unit” and tried it. The issue I found, at least with this workflow, is that you need to model everything in 0.000 mm, so it modifies the unit in Blender too. Do you know if there is any solution where I can set the export to get multiplied in scale without modifying the Blender scene units?

Have you applied the Scale Transformation to the objects?