Scaling of UV Map doesn't match object

Hello everyone,

at this day I never made a scene with complex textures, because everytime something was wrong with the UV Maps and I couldn’t figure it how I could fix this.

Now I wanted to give this another try and so I watched some tutorials on youtube about textures on simple boxes/cubes to start from the basics again.

I started a new project and setting up scene. I wanted to try a cardboard box and made a cube, 0.75m x 0.5m x 0.5m. Now I followed every step like in the tutorial:

I selected the cube/cardboard box and pressed CTRL + A and selected “All Transforms”. Then in the Edit Mode I selected everything from the object with the key A. Then i pressed U and selected “Unwrap”, then U and selected “Smart UV Project”. Now in the UV Editor the map looked like this (1. screenshot) and the scalings were off for some reason.

So I started over and thought something must be wrong. I deleted the object and made a new one. And after the second try it worked and looks like the 2. screenshot. The scalings of the map make sense.

This was yesterday. I saved the project and finally went to bed peacefully…

Today I opened the project again and wanted to try the same procedure on the same object. But… the scalings of the UV are changing to something wrong again (3. screenshot)
There is also a error message when I “unwrap” the object. But I don’t know why this is happening, i changed nothing on the object itself.

What am I doing wrong? I can’t figure it out and I think I’m going crazy.

Thanks for your help in advance.

Is the texture square? non square textures can gum things up a bit, you can also try unchecking ‘correct aspect’ and see if that changes anything for you.

I don’t know where your initial UVs came from but the second screen shot shows unwrap smart with additional Iland Margin 0.01… the error message appears if you do just select unwrap… those are two different things…
so maybe you was too tired to notice :sleeping: ??

Thank you very much for your replies.

@SterlingRoth was right. I set a texture to my object but the texture was non-square.
When I deleted the texture on the object and tried the “Smart UV Project” the scaling was normal…

Sorry, I feel really dumb, but I didn’t know this.

Thanks again for your help from both of you!
Have a great day.
My Problem is solved.

1 Like

Don’t feel dumb, there’s lots of little things like this thst just take time and experience to figure out.