Scatter 🌱 [The Scattering Tool of blender 2.8]

They are not around the cursor, they are in the center of the plane. :slight_smile:
blender does when the scattering is distributed based on an empty vgroup (weird blender behavior).

and the vgroup is empty because you toggled “Distribute on an empty vgroup” option in the security feature :slight_smile: (this feature is meant for weight painting)

by the way scattering on a 500x500m planes will give you maybe too much particles that you will be able to handle, be careful with that.


Awsome addon and also Luxcore’s Geopattern is on it way


You are right, blender is not responding. Will try with smaller plane. Is there any workaround to scatter on larger planes?

Hello, How can I get or buy the latest version? Thanks for this amazing addon!

1 Like

coming soon :slight_smile: ± a week

1 Like

This looks like it is going to be a killer add-on, if you don’t mind I have some questions :
1- Is it going to be free or commercial ?
2- Regarding the technique for the grass you made what did you mean by using the cluster map to distribute clusters ? does every color in the cluster map resemble a particle system with one of the various grass objects in the other image ? if so, doesn’t this mean that -unlike your render- the area with the widely spread grass should have very few grass, right ?

Sorry if I am not clear enough, wish you luck with the add-on !

1 Like


not it’s a commercial addon , there’s going to be an addon then a substantial library of biomes.

basically i meant that the “packs” of grass need to be distributed with a noise texture

Here’s a scene I made using this addon:

1 Like

Great! Really looking forward to buy this one. I have been following all along. @BD3D I tested the available versions on this thread but couldn’t check out the version after 1.14v2 I sent a tweet message to you as well but seems like your queue full with your beta testers. Please send me the link when this product is out to buy, I have also bookmarked this page anyway :slight_smile: to checkout the updates. waiting desperately for this.

1 Like

@BD3D, Thanks for sharing the V20,

90 turn is not working now, It was working on the previous versions.
I tried reopening the file, imported the same grass mesh again but couldn’t get it to work.

Hi Again,
The 90 rotation button works if I apply the rotation of the object.

Hi :slight_smile:

If your object xyz rotation is on -90 already there’s no need to do it again :slight_smile:

If you are not familiar with blender particles system then this tool may be confusing to some.

Quick Test with scatter beta 02.

It took 10 GB to render.
Unable to paint on imported obj file. so created a procedural texture to distribute the trees.
Ground texture done procedural


whoah nice render !!!

few questions :

Unable to paint on imported obj file.

why so ?

10 GB

this seems not normal, did you use a lot of microdisplacement ? why thisvram count is so high for a simple scene like that ?

My first try with scatter beta, I’m loving it!
I still can’t figure how to change particles density after applying preset but it doesn’t matter because I can do that in the standard particles hair settings.
Made with free grass assets from (artist Mischa Winkler)


woah !! nice render !!!

Really ? you can’t miss it it’s kind of obvious


all red are options dedicated for density
the density per/m² km² or density x2 /2 is really a must have, i always use it.

Go check this out guys ! i’ll show the different layers tomorrow


Thanks @BD3D. It was too slow to paint.
no micro-displacements used on that scene.

I am trying to load test Blender & scatter add-on on a new scene with 5km terrain.
I am using a terrain with 4.19 million polygon and default cube to scatter.
Enabled Display particles as bounds on creation.

The following list shows the memory usage that blender shows after each step.

  1. Empty Blender scene shows - 50.5 MB mem
  2. After importing 467 MB OBJ file it shows - 1.82 GB mem
  3. After Shade Smooth - 1.87 GB mem
  4. Scattering a simple cube shows 50% display - 2.08 GB mem
  5. When i change display % to 100% - 2.85 GB mem
  6. When i click New Paint Layer it shows - 2.92 GB mem
  7. After clicking brush button it shows - 4.07 GB mem
  8. It takes around 6 seconds to see the painted stroke. Its too slow.
    By enabling realtime viewport visibility blender stopped responding for 6 minutes
    and after that i was able to see cube scattered through out the terrain
    and it shows -7.45 GB mem now
  9. After reducing display % to 50% - 7.94 GB mem
  10. After clicking Add Influence to selected system - 8.94 GB mem
    weight paint is inverted
  11. Enabling Invert System Group - 8.75 GB
    Cubes disappeared
  12. By clicking add / remove particle toggle - 8.99 GB
    after 3 minutes i can see the cubes in the painted area .

8.99 GB Memory taken to scatter a default cube on a 464Mb OBJ Terrain which is 5Km in dimension.
I believe these memory issues are not related to scatter add-on. Blender needs some serious memory optimization.

1 Like

In case its whats happening here - its worth noting that I missed the “Tweaking” section initially because it appeared ABOVE the Preset section. I scrolled down and down and couldn’t find those controls until I scouted them out up top.

4.19 mio polygons is huge, and probably should be optimized. So slow down while painting is normal. Vertex color based distribution require a lot of computation for each particle and is known to be slow on huge data sets.