Scene issues, freezing etc

Computer: HP 2800 with latest BIOS , 2 Xeon 5650 processors @ 2.67mh, 12G Ram, GTX 780 ti with latest BIOS
Blender 2.74

When I started putting together my scene I was using a Quadro 2000 card and all was well until one day Blender started freezing. Until then I worked in a split screen with one of them in render preview of 10 with no issues. So I figured I built the scene too large for the Quadro card and I got the GTX 780 ti. The card seams to be running fine in Benchmarks etc and I rendered a couple blender scenes from other people and it seams to be working fine… but as soon as I open the scene I’m working on its so slow and freezes and forget about using the rendering preview or even border rendering. It will freeze up. The GTX doesn’t seam to be any improvement for this scene.

If I open a previous version of this scene which is about 1/2 the size in Verts , Faces and Tris I can turn the preview up as high as I want and it will keep calculating as I work with no issues at all and seams to be very fast.

Current Scene : Verts: 14,634,705 Faces: 11,250,023 Tris: 13,199,682
File size = 1.53g
Would this scene size be considered extreme for my hardware?

I do notice that when Blender loads the scene I see it flash some writing and it says something failed but it opens the file. I can’t read it as it’s too fast. Is it possible the file is corrupted or is the scene just too large…

Appreciate any help I can get…

Hi, all over 10 Million faces is extrem for Blender, independent from system.
GTX 780Ti is a fast card but only 3 GB of VRAM and if you use it for display to you loose 3-400 MB for system and 3-400 for Blender.
Check the VRAM memory usage of the previous scene during render, there are several tools to do.
Your 12 GB RAM should be fine to handle such a scene.
May you can make a screenshot from the scene, upload is a big heavy.
There are some tricks to handle such scenes:
Don´t use subsurf in viewport and max 2-3 maximum for objects.
Use layers.
Use wireframe mode, not solid for work.
Use / from numpad for single view.
There are some speedups in later Blender versions, 2.74 is really old, check 2.77a or check daily build from builder.blender.org.
You can use different versions of Blender at the same time, use zip files not .exe and extract it where you want.
Start Blender from a command shell (cmd), may you can see the error message.

Cheers, mib

mib, you are 100% right… I loaded my scene using CPU instead of GPU with a preview of 2 and I could work in the scene. Definitely a lack of memory on the card cause I loaded the scene again with GPU and this time when it froze it said out of memory. I will try out your suggestions.
Is there a way to mask out parts of a scene so calculations aren’t done on that section? Would be nice to be able to mask out sections that wouldn’t influence what’s in the camera view too.
Could there be any issues loading a scene that was made in 2.74 into 2.77a and I should be cautious and keep the old version of 2.74

Greatly appreciate the help

I was setting up my scene for an animated flyover where automotive parts would fly thru the scene and land on the cars.
So I looked over my scene and thought how the camera would do this and what was in the scene that wouldn’t be in the camera view and I deleted a lot of Hedges which so far saved me 3.5 million of each Verts Faces and Tris. I will probably use a photo on a plane for a background if needed. I have some courtyard tiles with subsurf that I’m not even sure I need and may be able to remove subsurf if it doesn’t change it too much.
I tried using wireframe and it looks great on building but grass, hedges and the courtyard tiles makes it look crazy and too hard to work in. I have some trees I purchased with what I believe is called a bounding box so you only see the item when its rendered so I need to learn how to do that and do it for all trees, grass, hedges so it makes it easy to work in the scene.
Thanks

Hi, should be not a problem to open older file in new Blender but you can keep 2.74 for a while.
I have several Blender versions on my system, own builds, custom and older versions for testing.
You can set bounds/wire in Object tab > Display > Maximum Draw Type.

Cheers, mib

Update… I shrunk my scene down to 6million Verts and now I can work in a split screen with one screen on Rendered Preview and I don’t have any issues at all. So from my experience getting a graphics card with the most memory is more important then speed when working in a 3D program with a large scene. When I started having huge issues my file size was 1.5g… now its down to 705mb and all is well which is about 1/4th the size of the memory of the card.
Anyway, thanks for all the help and I hope my info helps someone in the future.