Scene lighting changing between two specific frames in render even though no keyframes appear there

Hey! I’m having a hard time isolating a scene lighting change that happens between two specific frames in this project.

When I render out the animation there is a quick change in lighting between frames 139 and 140 as if there were two key frames at those two frames, but I can’t find any there. Also no change is visible between those two frames in material preview when toggling between them.

Here are the frames after rendering. The change is subtle, but not so much when the animation is playing –

estefprueb1 estefprueb2

Here’s the animation workspace when everything in the scene is selected. You can see that no keyframe exists on frame 139, although it would need to for a change to happen between that and 140 –

I’ve tried turning off 10 or 20 of the lights in the scene (in the viewport, camera, and render) which I thought would most likely be causing the change, but it is difficult to do that with all of them because there are hundreds in the scene, and I would have to re-render the frames every time. I’ve also tried removing the node setup for world shading, but that didn’t eliminate the problem either.

I am on Blender 2.82, but I tried rendering it in 2.92 and the problem persists.

What am I missing here?


There is a key frame on 140 and 141, and you are starting on frame 2. If you load in the images in another file that starts on frame 1, they would be offset by a frame, making the change happen between 139 and 140.

1 Like

Thanks for that tip, I hadn’t noticed that. The problem turned out to be something else - I had a material in one of my objects with a MixShader combining a Emission shader with a Principled BSDF shader whose Fac value was animating to 0 at frame 140, and for some reason although that change happened over the course of more than one frame, when it hit 0 exactly the lighting made that sudden change. I assume it has something to do with the camera exposure, but I’m not very well versed in those settings.

Anyway I solved it by changing the value in that key frame to be a value close to zero but not exactly zero (0.001). For some reason that stopped it from happening.

1 Like