Scene Looks Miniaturized - Please help.

I’m having problems with my scene that I can’t figure out how to fix. I’m trying to render a good looking Minecraft environment, but I’m getting this “miniaturized” effect I’m not sure how to get rid of.
Any help you could give me would be welcomed, thanks.

One thing you can’t do is scale the camera. So you are left with scaling the objects. In Blender the default cube is 6 feet. If you have some trees in the scene, as shown, think about how tall you want them to be to the camera. Use the grid plane (each square is a meter) to determine a better size for all objects. CTRL-A S10.

You can also enable depth-of-field. This helps the eye determine distance in a still scene.

You can’t scale the camera but you sure can use a narrower zoom. Along with Atom’s suggestion I would add this:

OP, try turning your camera lens down to a 30mm or maybe 25. More perspective will give a sense of a larger environment. The problem you run into is now the scale looks good but it also looks far away. You should try and get the camera up in the environment. Use multiple shots and composite them together in the VSE to get a full sense of scale. No reason to just plop the camera in one pretty far away position.

Good lighting will help too. Try putting a sun lamp in there.

I changed the camera MM, added focal length, and even though I’m in cycles and already had lighting, I added a sun lamp for good measure. I didn’t see much improvement :confused:

My goal is to have a far out shot, I don’t want to compromise for a close up.