Scene wont set?

Hey guys. I have a main menu in a scene called, gasp, you guessed it , main menu. Anyway, I set up all of the buttons (start game, credits,exit game). I wanted to xset up a left mouse button sensor on the start game button to set the game scene. When i tried it out, it flashed the game scene for a millisecond, then it ended the game. Any answers? Thanks- Drew

to help you we need more information about your settings!
Do you use Logic Bricks?
When you click on the start game button did you connected it with a setScene actuator?
Does the games scene crash also if you run it without the menu scene?

open the system console and check for warnings

@Nickdiesel Yes, Yes, and no.

@Monster Console is fine. Only Blender game engine start and blender game engine finished

Well, maybe you should post a blend file. By the way, is it crashing the BGE, or just ending the game? It might be that you’re somehow clicking “Exit Game” right when it loads the next scene.

Just ending the game.By the way, It wont let me attach the file? :spin: I also tried it on Pasteall but it says “File could not be moved”. Any suggestions?

And @nick it doesnt crash it just ends the game

Try a site like, or MediaFire.

Ahh. Thanks solarlune. Heres the blend,

The mouse click sensor just works based off of mouse input, not position. Left-clicking will cause the blend file to end game, and this is because you have a Left Click sensor hooked up to end the game on the Exit plane. You need to connect a “Mouse Over” sensor to the controller connected to the left mouse button sensor so that it will only end the game if you click on the button.

Hello DrewH, I just took a quick look at your blend and you have 2 little problems one is with how you have your logic bricks set up. You have the logic on the plane underneath Story set to go to the next scene if you left click and the plane underneath exit you have it quit the game if you left click. The problem is that the both execute since the only sensor they use is the left mouse click.

To fix, just connect a mouse over to the controller that is connected to your set scene actuators on the planes :slight_smile:

the other problem is that the plane underneath “Story” is at the same position as the background, just raise it up a little so mouse over will work with it, hopefully that fixes your problems

looks like SolarLune answered your question already :stuck_out_tongue:

Thanks all :o I really appreciate your help!