SceneCity ⛫

add-ons
procedural
architecture
commercial

(Arnaud Couturier) #1041

Everything looks fine…
Has SCG ever worked on your computer ?


(Aenima) #1042

Yep, worked before. Now if i generate city without popmap SCG works. But if i try ti use popmap Blender quits after hit exit.

I cant see any important in terminal:

Aenima:MacOS aenima$ ./blender
ndof: 3Dx driver not found
Read new prefs: /Users/aenima/Library/Application Support/Blender/2.71/config/userpref.blend
found bundled python: /Applications/Blender-2.71/blender.app/Contents/MacOS/2.71/python
fake_module: addon missing ‘bl_info’ gives bad performance!: ‘/Users/aenima/Library/Application Support/Blender/2.71/scripts/addons/UvSquares.py’
SCG starts city generation…
java part done in 7.240628004074097
java said:

You can grab the crash log from here: http://b3d.hu/scg.txt


(Aenima) #1043

On windows i get a bug but its Java related. On Mac i get weird result. Most of the time Blender crashes, now no matter the popmap used or not.


(Arnaud Couturier) #1044

I can’t reproduce your problem. Are you using an official Blender build, from blender.org ? Not an alpha or custom build ?
Also, what do you mean by a bug that is java-related ?


(Aenima) #1045

I use a custom build - Octane Render version. I try to use SCG with a vanilla build.

Thanks your fast reply.


(Freezeframe) #1046

Hi, do you know how to deal with this error here. I didn’t go through the 50 comments!!
IDK tried it awhile back maybe I even left a post somewhere. IDK Anyway.
“java.util.prefs.WindowsPreferences <init>
WARNING: Could not open/create prefs root node Software\JavaSoft\Prefs at root 0x80000002. Windows RegCreateKeyEx(…) returned error code 5”.



(Arnaud Couturier) #1047

Hello. This warning is benign, but to avoid it, you should launch Blender with admin rights. In Windows, right-click on the Blender executable, then “Run as Administrator” (or something like that).


(Aenima) #1048



Hi Piichan i tried an official version pf blender but no luck. The funniest thing is it works on OSX. Same version, same setings and all went ok. But on win8.1 x64 i get error and a message about the scripts line 398


(Arnaud Couturier) #1049

Mmmhhh… never seen that error before, or at least nobody reported it.

  1. Does it always fail on Windows ?
  2. Are you using the same Java version on OSX and Windows ?
  3. Are you using a heightmap ?
  4. Also, what is the upper part of the error message in the second image ?

(Arnaud Couturier) #1050

New demo video of the upcoming version 0.7

Video description:
First person navigation in a generated city. This is the realtime preview, not the final quality render.

The cities in version 0.7 of the generator (due very soon), will look much better. Plus you’ll be able to view your cities from the sky, like before, but now also down to the street level.

When you’re happy with a city, export it to Blender, so you can further work on it as you like: improve the buildings, add stuff like cars and people, then render it with a better quality using Cycles or Blender Internal render engines (the city materials work in both).


(Auuman Anubis) #1051

Holy goodness! That looks very promising!
You’ve rejuvenated my hype for this. This looks amazing!


(SHABA1) #1052

Ok I am confused. I have seen announcements on this thread for version 0.6 and not for version 0.7 but when I go to the website all I see are links to download the free and full version 5.7.5 Am I missing something?


(Auuman Anubis) #1053

In the newsletter, he said that version .6 was too large a project to do right now (it’s a complete recode from the ground up) So he wants to make a new version that continues from the foundation already made.

That version is 0.7

The website hasn’t been updated yet because 0.7 is still WIP, and won’t be ready until closer to 2015.


(Arnaud Couturier) #1054

Thanks Auuman Anubis for the encouraging words, and for clearing things for SHABA1 :slight_smile:

If version numbers are still confusing, I’ve explained the reason in detail on the blog


(olyrick) #1055

when I try and make a city I get an error .



(Ko.) #1056

Need to find

use_premultiply = True

and change to

alpha_mode = ‘PREMUL’

just a guess :evilgrin:


(olyrick) #1057

and where would i find the code to change it?


(Ko.) #1058

file SCG_output.py line 24, I believe…


(olyrick) #1059

wrong addon sorry

Attachments



(olyrick) #1060

here is the right one.

[ATTACH=CONFIG]341809[/ATTACH]