School computers won't run Blender well

The computers at our school have problems. They’re in my 3D Animation class, and they run Maya and 3DS Max just fine. However, after I install vcredist on them along with Python, Blender will still not run properly. It runs fine to a point, but if I have too many polys (about 128 seems to be the maximum it can handle without crashing, so too low poly to use), if I do ANYTHING in edit mode, even selecting vertecies, it crashes. The computers have deep-freeze on them, meaning I can’t install anything permanently (the computer reset to a default image upon reboot), so installing drivers isn’t an option.

Here are the specs of the machines, which are of the “Dell Precision 380” type:

Intel Pentium 4 2.80Ghz dual-core
nVidia Quadro FX 540, 128 MB

Besides the crashing, I get weird artifacts on smoothed objects when in Solid or Textured view. And, I don’t see where to attach an image here, otherwise I’d show you.

The crashing happens independently of the view type, though. Doesn’t matter if its all solid (unsmoothed) on wireframe, it still crashes.

I’m not blaming Blender, because Blender runs fine on all the other computers I’ve tried it on. Just doesn’t work on these computers in my 3D class.

But, is there a copy of Blender compiled on this type of machine, or a way to run Blender? Because of restrictions on the computer, I can’t run a command prompt, nor can I install any compiler to compile it myself. Also, running Linux off a live-cd doesn’t work, as it skips the CD drives on boot, and I can’t get into CMOS setup.

can’t you ask the admin to make blender work properly? he’s apparently a very capable guy. :wink:

looks like an opengl/graphics driver problem to me. recompiling blender on that machine wouldn’t help.

The admin is an idiot. The screens are a full 1280x1024, and the program we use, Maya, REQUIRES that resolution as a minimum, but the screens are set at 1024x768. And, the restrictions prevent us from changing that. However, I got a little “Resolution changer” app that lets me.

I would agree with that, except that even with wireframe, which has no graphical glitches, it crashes on an actual tool. For instance, beveling or extruding. Not on stuff like rotating.

But, only in Blender, and not in Max/Maya. Also, Max/Maya are set up to use OpenGL, and they don’t have a problem.

The Quadro is a pro-based card and probably uses different drivers from the normal ‘run of the mill’ Ge-Force based machines you’ve usually used.

Id say either a graphics driver problem or maybe a user account restriction problem.

Have you tried downloading the all-in version that you just unpack and run, rather than installing? Try that and see if that flys.

And the admin doesn’t think he’s an idiot, he just thinks you’re some sort of jerk.

That’s the only version I use. I run it off my thumbdrive.

ever try older versions of blender? just an idea that suddenly pops up … not that there is some firm technical reason that i based on :stuck_out_tongue:

witch drivers are installed, there are multiple drivers for quadros,
and they are specifically geared towards specific apps.

heres a list of XSI specific drivers for an example:

partner certified(with entry for blender):

I don’t know, but I know that they update the computers with software once every two years… Unfortunately, they updated them over Christmas time, so it won’t happen again while I go there :frowning: