Scraggly pixels painted in 3D view

After fixing a problem with the graphics driver, which followed many clumsy attempts to fix the problem, I have this in the 3D view (magnified 3x, no interpolation):

This even affects the nodes editor:

The scraggly displace pixels look bad, but usually go away if I move the mouse cursor out of the 3D view pane to any other.

The original problem to be solved was the whole Blender window contents blinking out, appearing only when the cursor ran over controls when sliding/rotating the view. That was solved by turning off compositing in the X windows driver (through a GUI tool, ugh.) I’m running Ubuntu Linux with an ATI board, two monitor setup. Everything else works fine.

In the course of fixing that problem, I had tried changing settings in Blender, such as Window Draw Method, anti-aliasing, and who knows what. Maybe I screwed up something? But none of that should matter, since just yesterday I upgraded to 2.69 (was 2.68) and the problem persists, although all settings are fresh factory defaults.

What is causing the scraggly pixels?


Try disabling Multisample in the User Prefs (meant to anti-alias lines in the viewport) - I’ve had some trouble with it before.

I think in 2.69 this was enabled by default, hence the sudden change.

Odd. It was already off. So I turned it on. Then turned it off. Now the scraggly pixels problem is gone!