Screen Node over-reacting

Hi, I’m having a bit of a problem with compositing.

I set up a simple scene with the Cycles Render Engine. (I’m using Blender 2.63) I wanted to use a “Mirror ball” texture mapping for the background. So, I added a ground plane, put it in a separate layer, and planned to add the shadows via compositing. Problem is (and I’ve had this problem before) all of the filters are acting really weird (See picture for reference)
The Screen filter has only two settings, either completely on (at any setting above 0.0) or off (at 0.0).
Also, as you can see from the picture, when I turn on the multiply filter, for some reason the background turns white.

I’m probably missing something simple, or - even more likely - am making this much more complicated than it needs to be. Please let me know if you have any advise!

Thank you!