Screwed radiosity lighting.

I’m not very familiar with radiosity lighting in blender yet.
During my first experiments, I have encountered a strange problem.
The image below shows a simple wall with some radiosity lights.
As you can see, the lighting doesn’t look smooth at all, though the corners of the tiles are rounded and the normals are correct.
I tried decreasing the patch size by reducing min- and max-patchsize, but that didn’t help.
What do I have to do, to get a nice smoothed lighting on the corners?

Can you post a .blend file?

Hm, I could do that.
But not today, I can’t get the files from own PC to this one right now.
I’ll send it tomorrow

try turning hemirez all the way up [radiosity buttons are under the shading buttons, like the material buttons]

Thanks for the tip. I’ll try that as soon as possible.
Anyway, here’s the blend file. Just in case.
Edit: Link updated! I uploaded the wrong file before.
I tried increasing the hemires amount, but it still looks very strange.

hm, did you render with ambient occlusion turned on? not sure if it would explain the artifacts, but to me it looks like AO…

As I said, I’m not very familiar with this stuff, yet.
Where can I switch on/off AO?

Go to the world buttons ( F8 ), hit the tab “Amb Occ” by “Mist\Stars\Physics”, and see if the “Ambient Occlusion” button is depressed or not.


That one is off.

Hrm, that’s a very tricky one. It’s because the radiosity is calculated per vertex/face. Since your geometry has heaps of faces around those square edges, there are a lot of different radiosity calculations going on, and for some reason they’re getting different results (not smooth). Your two options are:

  • Re-model the geometry to have a more even distribution of faces and vertices across the surface (hint: using Simple SubSurfs can help here)


  • Use the fine art of faking it.

Since what’s in that scene can be sort of done with area lamps, I rendered out a version (.blend) using raytraced area lights and ambient occlusion. Here’s the render:

Thanks for looking at the blend file.
I will try out what you suggested.
Though I tried it with normal lights already and it wasn’t what I wanted.
The splices between the tiles were too dark, that’s why I tried radiosity to get a more realistic lighting.
What does AO actually do?
For some reason the .blend does not exist.
“The requested URL /blender/etc/ was not found on this server.”

AFAIK ambient occlusion is some sort of distance-based shadowing. it also takes into account wrinkles and creases of the geometry, making those parts darker. this is why sometimes this is also called “dirt-shader” - wrinkles and creases tend to become darker in real life due to the fact that dirt gets there and is hard to clean :slight_smile:

Argh! Sorry, shouldn’t post late at night without double-checking :wink: