Script to run Blender does not run the python auto execution

I put some drivers in a scene with scripted expressions. The python scripts are disabled by default on startup so I have enabled that in preferences (Auto Execution: Auto Run Python Scripts) and hit “Save User Settings”.

When I run the command line script my programmer made to do a specific job, blender opens and it is as if the python scripts are disabled.
The driver I set to scale an object, just scales it to zero.

To narrow it down a little. The update dependencies button on the driver does nothing. Until I go into preferences and uncheck / recheck the python scripts box, then click on one of the drivers’ update dependences button.
Then it works.

I followed the link to here:

So this may help:

I need to improve the command line script to open Blender and run the driver scripted expressions.
I need advice to help figure this out. I know Blender but my programmer does not.

I think this may be what I need:

-y (–enable-autoexec) enables
-Y (–disable-autoexec) disables
Both these options override the startup .blend auto exec preferences (including when used with --factory-startup) allowing auto execution. Note that it does not edit the preferences (even temporarily), it just allows execution.

Yes this worked. There was already a parameter to run a python script (-P) and related files and directories listed in the command line script. I had to put -y right at the end, after the references. If I put -y -P (or vice versa) it stopped the python script from running.