Scripts not showing

Problem solved!

Hi all,

I’m running Blender 2.44 on Ubuntu 6.06 LTS. When I was using Blender 2.43 I noticed the scripts didn’t work. Now I’ve installed the latest Blender version they’re not even showing. I searched the forum and found this tip:

Which operating system is this on ? (Win / Linux / Mac OS) ?
I’m not sure about Mac, but on Win / Linux, <BlenderInstallDirectory>.blend\scripts … should have 103 scripts there. So check first if the scripts are even there. If they are, you could try opening a scripts window then choose “Update Menus” from the Scripts Menu.
Done that, but it doesn’t help (the scripts are in that folder, but they don’t show up in the menus).

What could the problem be? How can I check to see if I have the right Python version installed?


By default Ubuntu 6.06 LTS runs Python 2.4 (I have a Kubuntu 6.06 installed) but perhaps you installed the linux version for Python 2.5. If you want to compile your own Blender for Ubuntu 6.06 you will find a guideline there:

Thanks for replying oliveS!
I found out for sure I have Python 2.4, so I installed the Blender version for python 2.4 thinking I might have gotten the one for 2.5. The problem persists however, so now I’m out of ideas as to what could be wrong.

About compiling from source, are you recommending it as a solution or just suggesting it because you thought I might have done that but got it wrong? If it’s not likely to solve the problem I’d prefer to just go with the precompiled version (which I have now) as it’s less trouble.

Thoughts anyone?

It’s weird that the scripts don’t appear at all, if they exist in the right folder (.blender/scripts if I recall correctly). In the Scripts Window, Scripts > Update Menus but your case is so weird I doubt it will help. Just try in case… :-/

Compiling could be a solution, but not sure. Everything should really work out of the box. If you want, this evening (french time) I could upload a build I made out from the SVN trunk and you could test it if it solves anything for you. But please check Update Menus before…

I updated the menus before and tried it again now, but no luck…
The path is .blender/scripts as you say and I got it by using the directory navigator to make sure I wasn’t making some typo, so that should be fine. Is there some global variable or anything that Blender looks for but may not be able to find?

Yea, I don’t know what the trouble is, but the scripts don’t show and the extra import and export options don’t either (these are scripts too, right?). Otherwise everything works just fine. I thought it might be an old version of python or something because Blender 2.43 showed the scripts, but they weren’t working and now they are gone from the menus (they are present in the right directory though). So I thought maybe as I upgrade further away from some old dependency the program has an increasing amount of difficulty. But python seems to be installed just fine. (Is there a way I can make sure everything is OK with the python installation?)

I’d appreciate it if you could upload the build. I’m on dutch time, so pretty close.


Did you messed anything in the User Preferences? Perhaps you changed the path in the File Paths? To make sure, delete the .B.blend and other Blender config files in your home… This way, you should revert to a brand-new blender…

Yay! It worked! Something in the user preferences must have messed it up. Can’t imagine what, but that doesn’t really matter now. All the scripts are back and they work!

Tanks oliveS! I owe you a drink.

:wink: Perhaps I’ll be around for the Blender Conference, if you don’t hide from me :stuck_out_tongue:

Haha, well, let me know in that case.