Scroll/pan UV view? (MMB not working for me)

I’ve looked it up and supposedly the UV editor window can be scrolled/panned by holding MMB and dragging. Doesn’t work for me. Nothing happens. Any other way of doing it?

(TBH this is bonkers inconsistency in the gui, since it would be logical to just make the view follow the frigging cursor like it does in 3D view. People expect things to work consistently.)

By default, panning and zooming in the UV Editor is the same as panning and zooming in the 3d viewport

Pan = Shift+MMB
Zoom = Ctrl+MMB

Also because you cannot rotate in the UV editor, MMB also pans

If it doesn’t work for you, what have you changed. try with the factory settings

to just make the view follow the frigging cursor like it does in 3D view
By default it doesn’t

Well, there’s a handy and obvious setting to make it follow the cursor, and IMHO it would be logical to allow that in the UV window as well. That’s the only cursor setting I’ve changed. Apart from that it’s all factory.

I can’t get MMB to do anything except zoom in UV view. Could possibly be a dodgey mouse wheel I suppose. Is there keyboard a11y for pan/scroll in UV?

File / User Preferences / Input

OK nvm, I’ve found a workaround by trial and error. Ctrl+Up arrow expands the UV editor to full screen height. Ctrl+Down arrow shrinks it back to where it was. This is workable for me, since I have 1200 screen height and the game I’m mapping for has 1024 max size on textures.

ETA: Posted while you were posting. Thanks. I’ll look into custom keyboard settings when I have time to double check that I’m not borking things by using something Blender already uses.


Ok, so I went into the global image section of user pref, and reset pan view to Shift+LMB. Saved settings.

I go to the UV window, hold down Shift+LMB, and try to pan the view. Nothing happens. View stays resolutely fixed.

We ask, why is this so? :slight_smile:

Just to clarify something: is it necessary to reboot Blender before custom interface settings will take effect?

Ok, nvm. For some reason the other custom settings I was trying wouldn’t work, but Ctrl+Alt+LMB is now working.

Try enabling the Emulate 3 Button Mouse feature for a (default) Alt + LMB pan view shortcut to magically begin to work.

User Preferences > Input > Mouse > Emulate 3 Button Mouse (checkbox).

Yup, that works too. I’ve ended up going with Shift+Alt+LMB anyway. I like it. YMMV.