Sculpt Layers Addon

Aparently the number of vertices is the same between meshes. My main problem is that even after I collapsed all layers and clean ui I still cant use new layer on this mesh. When I tried to turn off my new layer I get the error that I showed you. I tried changing the name of my mesh, the name of my data mesh, the name of my multires modifier but the error persisit. The only way that I make it work again was by copyng my mesh to another blender file and then I created the layer there and its fine. But I need my mesh on the same scene but I cant copy that mesh back to my scene and preserving the layer.
Unfortunately my mesh is under NDA, I cant share it… I just need to know a way to efectively reset the layer and make new ones work. Thank you

I cannot help you without looking at the mesh. I assume there was a change in the mesh. You can ask your manager to send me one object. You can delete all other objects in the blend file.

I finally solved my problem. The problem was that I had simplify activated with 5 subdivision max and I was creating a layer with 6 subdivision on sculpt mode with multires. Aparently the base sculpt layer data was being created with 5 subdivision because of simplifly and it wasnt matching with my layers. It would be good that this addon doesnt take into account the simplifly setting if possible.
Thank you for trying to help, your addon is so useful.

1 Like

How is Blender 3.0 compatibility? Blendermarket page says nothing about that.

It should be fine. But there will be a new update according to 2.93+.

Thanks. The use I’m considering this add-on for is skin detailing on highest multires level with 10M verts or more. Earlier you write that save/hide/unhide layers takes about 17 seconds on your machine, with 16 million verts. Will eg. adjusting layer strength take similar amount of time?

Unfortunatelly, it will take some time to save/edit values. The main problem is that I have no access to the Multires-modifier to change points positions. The amount of time depends on a machine.

But, sculpting works without any delays.

Basically, you sculpt details, then save them.

I am just wondering how the connection to zbrush is currently going. Do you think it would be possible on future updates? This would be really useful for me because I only work with people who use zbrush.

At the moment I’m not sure if it will appear as lots of work to do. But who knows… Maybe in future.


I created a brush manager for Blender called Rune. I hope it will help you in sculpting.


Hi Artists,

Sculpt Layers V0.5 is released and this is a major release. V0.5 is not compatible with previous versions but you can convert layers of an old version to a new version.

  • Updated UI.
  • Layers are moved to Attributes of a Base Layer. Thanks to Geometry Nodes.
  • File size is less now to 10-20%.


Hi Mifth, sculpt layers version 5 works with Blender 3.0 however not really working with 3.1 beta, is that due to geometry nodes changes blender underwent not long ago (attribute v fields)…and will there be a fix, or have I done something wrong??

1 Like

Hi Ivan,

Actually V0.5 should work with 3.1. Do you have any errors?


My apologies Mifth, it seems to be working now (maybe a reboot of blender might have fixed it)…the error I had was that the layers were saving, however when the layer visibility was disable the sculpt information on that layer remained visible…sorry mate!

1 Like

No worries, poke me if you will have any errors.


I’m also seeing Sculpt Layers not functioning correctly in 3.1 (which is released now). When I toggle off a layer the sculpting deformation goes away but the lighting stays as if the geometry was still deformed, and then if I toggle the layer back on nothing changes (no errors).

Can you please provide a simple blend file with steps to reproduce the issue?

Example 1: Default cube remeshed in Sculpt Mode at default resolution (0.1):
20220322-SculptLayers-01.blend (204.8 KB)

Example 2: Default cube subdivided with modifiers applied, shaded smooth:
20220322-SculptLayers-02.blend (884.0 KB)

Each example has 3 horizontal sculpted lines: the top line was drawn with no Sculpt Layers added, then I added the first layer (Layer_0) and drew the middle line, finally I added the second layer (Layer_1) and drew the bottom line.

The two examples behave differently (but neither work correctly), and in my testing I believe the difference is that the second is shaded smooth whereas the first is not.

Example 1: Turn off the visibility of Layer_1 and both the middle and bottom lines disappear, including lighting (bad, only the bottom line is expected to disappear). Turning Layer_1 back on does nothing.

Example 2: Turn off the visibility of Layer_1 and both the middle and bottom lines disappear from the sculpt, but the lighting remains as if it’s still sculpted (bad, only the bottom line is expected to disappear and the lighting is expected to update). Turning Layer_1 back on does nothing.

hey mifth can vdms vector displacement maps be possible in blender like we can use them like we use alphas

You need to save Layers manually.

  • Add a layer.
  • Sculpt details
  • Save the layer