Sculpt mode - lighting loss on pressing F

Hi All, I have a rather annoying problem when sculpting with textues applied.
Whenever I press F or Shift F to change the size or strength of the sculpt brush, the model looses all shading and appears as texture only, like ‘flat colour’ in Zbrush, or 100% Illumination in Max (apologies, reference to these other programs is for demonstration purposes only, and should not be regarded as encouragment to use either of them, Blender is now the only app I encourage the use of).
So, I have a tiresome work around to this problem, which is to hover over a UV\Image Editor window (with the texture loaded) and hit Alt - R. This reloads the texture, and also fixes the lack of lighting in the sculpt window.
Of course, this work around really destroys the flow of my work, so any suggestions as to how I might solve this problem will be greatfully received :]
I guess I’ve never really noticed this ‘glitch’ before as I usually sculpt without a texture applied, but now that I do, it’s very annoying!
Does anyone else have this problem?

If the Partial Redraw option in the sculpt rollup menu of the 3d view header is checked, you could try turning it off.

Do you have a .Blend file that shows this behavior? If so, please add a bug to the bug tracker ( or email it to me: [email protected].

Hmm, Partial Redraw was turned off, and if I turn it back on I get a completely blackk model :l
I’ll mail you the file Nicholas, thanks for looking :]
I went to the bug tracker and made myself an account, but haven’t put it up just yet.