Sculpting serious lag

Hi there,
(sorry of my bad english, but I’ll try my best)
For some reason, whenever I am trying to sculpt in blender the brush go so slow and stuck all the time so it is impossible to sculpt.
Do someone have any idea what can cause it? Even if my model have very low polygon number it happend. so it can’t be it.

Have you been playing with the user settings? this can cause these kind of issues,
Can you provide a screenshot of both your scene and your user settings? [specifically the “System” settings]

Cheers,

Jim Morren

Giving a screenshot of the scene willn’t help as it accure with any scene. here’s the user perefernces system setting:



thanks for helping me.

What kind of polycount do you have on the sculpt ?
Are you using Dyntopo, Multires or none of them ?
Are you using additional modifier on your sculpt , if yes which ones ?

a blend on which you experiment the problem would be useful

That’s it. It happens in all the cases you have mentioned. I thought maybe there is a botton that can solve it for me.

  1. Have you tried Triple Buffer?

User Settings => System => Window Draw Method => Set Automatic to Triple Buffer. [This COULD improve FPS, COULD!]

  1. Have you Checked your Stroke Method?

Sculpting => Toolbar [T] => Tab: Tools [Blender 2.71] => Stroke => Stroke Method [Check if it’s set to Space] => [if Space] set spacing between 5% -15%.

  1. Make sure you have no Recording Software, Music, Video or another Blend file Open!

If none of this helps, send the .blend file here and post the URL link so I can download and analyze the .blend file.

Cheers,

Jim Morren

Questions:

  1. How much RAM do you have?

  2. How many vertices are there?

  3. How much spare HDD space do you have?

  4. What is your OS? [Operating System]

Thanks Journeyman, Triple Buffer seems to help a bit. I have music of course. You don’t expect me to work without music… (by the way, the music sometimes stop for a sec during sculpting, as it happens in renders, like sculpting is a very hard task for my computer.)
The lag I have mentioned is sometimes just annoying and sometimes impossible by the way.
The problem is not in a specific file, and in large rabge if vertices amount. right now for the test I’m using a sphere with 98306 vertices. but I am having problems with 386 as well. (yes, just 386!)
My RAM: 8GB
System: Windows 8 64 bits
What is spare HDD?
Again, thanks for helping me.

What is spare HDD?

How much space is empty on your hard drive.

34.6 GB
Not a lot. You made me realize I should clear some space. Is it the problem?

No, if your problems happen on a 386 faces object, it has nothing to do with having 36gb of hard drive space available.

what kind of graphic card do you have ?

I assume you’ve been using the 64bits version of Blender 2.71 , so give a try to the 32bits version to check if there’s something in the 64bits compilation your computer does not like.

Sanctuary, pal, check out his screenshot…

Giving a screenshot of the scene willn’t help as it accure with any scene. here’s the user perefernces system setting:
/uploads/default/original/4X/8/2/4/824f9d785e0ffd29798b402ff765fa8bac68e1ed.PNGd=1404753908&thumb=1

He has a Geforce GTX 760,

That would do fine with sculpting, I mean I’m using an old ATI Mobility Radeon HD 4300 on one of my machines [4 year old laptop] and it works just fine at sculpting.

Oops, didn’t noticed the little box.
No reason for sculpt to lag with such a videocard, especially something that does “386 faces”.

Out of trying a 32bits version of Blender, i’m out of ideas then.
Is there any 3D application or game using OpenGL on your computer that you could check if they’re very laggy too ?
(if yes, it would probably mean the card driver you’re using may have problems with OpenGL and maybe installing another one could be helpful)

oke, one more thing, what are you running music on? Itunes or Youtube? if ether of these it could be the problem since they use a good mount of CPU processing, and sculpting is hard on the CPU.

TIP: While rendering, if your music stops, and you don’t care all to much for the render-times, go to “Task Manager” and then “processes” Right Click the application running your music and “set priority” to “Normal” or “Above Normal”. This is a one trick I use, the other is: Buy an Ipod! :wink: [I do both of these :yes:]

Try Crazybump [Free Trial] it has an OpenGL rendering system.

What CPU do you have installed?

Sculpting using the GPU?? I thought it is only on CPU.
I have tried this: http://stephaneginier.com/sculptgl/
this is working just fine and in more Vertex than I tried in blender to compare. I still think this is something in the setting.
My CPU: Intel Core i7-4770

I’m hopeless. my laptop can do better, this computer can sculpt in other softwares, I’ve tried to reset the pereferences, reinstall blender with the diffault setting, nothing worked!!
It is making no sense. It’s like the problem is not the setting, not in the computer, and not in the computer as it worked in the past. I simply can’t sculpt in blender with this computer. :frowning:

GPU as in OpenGL being used by Blender for the display of the mesh, not for the sculpting strokes calculations that are CPU, so a driver that has a very bad OpenGL support can make blender working far from great even on a good computer.

And as Journeyman said, the calculations are heavy on the CPU, so make sure you’re not running another applications that can be taxing the CPU in the same time

Give a try to Sculptris that is using OpenGL for the display, to see if this could be a the problem, it’s free and very similar to Dyntopo in Blender :
http://pixologic.com/sculptris/

Way back up top Sanctuary asked you if you had additional modifiers on the object. You seemed to answer yes but there was no follow up, in my experience when the hardware seems capable but there’s a lag it comes out later that there was a high subdiv on the mesh, and even worse sometimes a multires and a subdiv .

It have nothing to modifiers, I have tried very simple objects.
Do you mean I cannot sculpt in blender? It’s weird. because since I bought this computer I have sculpted and it worked just find.
because until a solution will found I can’t sculpt in blender, I have downloaded ZBrush and started to learn this. I don’t love learning softwares, but I have no other ideas.