Sculpting Slow.....Lagging while in sculpt mode

I am sculpting in Blender and I don’t have a lot of polygons as you can see here:
sculpt1

But I am experiencing so much lag. When I use Zbrush, I can get to creating the full body of a character, armor, and cloth at a pretty good detail with barely any lag. Why is Blender so slow? Is there a setting I must adjust? This is my preference system settings right now:

Blender doesn’t have the same performance as zbrush. It will lag at high res stuff.

But how are you doing it, dyntopo, multires, raw? With that small amount of polys it should be pretty smooth.

Hi Regnas,

I am working with Dynotopo. But it looks like when I went to Edit Mode and then switched back to Sculpt Mode, it started running better. Also depends on what tool I am using, when I use inflate brush, seems to lag.