SculpTkt - a toolkit for sculptors

I just tried the new Ellipse and Rectangle modes of the Slash Cutter, but they don’t seem to work. You can drag the shapes, but there’s no cut.

Tried it on the default cube, using the latest Master beta (July 22). The PolyLine mode does work.

For me it works.
Do you see any error message in the console?
Could you tell more precise steps to reproduce the problem, or a short gif/video, so I can see what’s happening?

This is what I do, in Object Mode, standard Blender startup scene:

The same goes for the Rectangle option. Only the PolyLine works fine.

Do you click/drag > release or click > release > drag > click ?

I click + drag then release. If I click once first, the Slash Cutter (and entire Sculpt Toolkit menu) exits.

I’m using a Wacom Intuos Pro tablet + pen, if that might be the cause. But that should simply emulate mouse operations.

I dont think it has anything to do with the tablet.

Just to dissect the problem, could you try, clicking and releasing then dragging? with a mouse also if you can.

Ok, I’ll try that. Be right back.

Tried it. Clicking once in Ellipse mode simply exits, I’ve dragged anyway, in case there’s an invisible ellipse, but no cut.

I’ll have to see if I’ve still got a mouse lying around somewhere.

No mouse in the near vicinity (desk drawers and such). I’ll have to go upstairs and search for it. If it’s essential I’ll do that.

I’m trying to reproduce the problem but It works with mouse and I don’t have a tablet lying around here to test it now.

Ok, I’ll look for a mouse in my little man cave upstairs. :slightly_smiling_face:

Had a look, but I’m afraid I’ve got no mouse anymore. I used to have an old Razer game mouse, but I remember the rubbery surface started to get sticky.

Sorry. If there’s anything else I can try for you, just let me know.

Don’t, worry, I think you gave me enough information, I’ll just do some tests, I have a guess of what’s happening.

1 Like

just tried the “put print calls in every variable of the code” debug strategy… never fails. Thankfully, is a fairly small addon
image
It was supposed to be only two points.
I’m sorry, I should’ve caught that before release.
I’m gonna fix.

1 Like

Hey guys It’s now fixed.
I already updated both blender market and github repo.
Anyone who is seeing this bug can download the new version already.

2 Likes

Hey Jeacom. Not sure if you have followed all the new changes that are being worked on to improve sculpt mode by Pablo Dobarro. Curious what you think about it and if you thought of any ideas based on what has been revealed so far that you may roll over into Sculpt Tools?

I am mostly waiting to see what’s gonna happen with sculpt mode.

Once the new features are settled out, I can think about what to do with the addon.
I don’t want to end it up with duplicated features like happened in the transition from 2.79.

Mask Deform and Voxel Remsh are already in the list of features that will be replaced with built-in features of pabblo’s branch. So I’m thinking about what I can add to keep this addon useful.

2 Likes

Two weeks ago or so I did a quick test comparing Sculpt Toolkit’s Voxel Remesh vs. the Remesh function in the Sculpt Mode Features (not to be confused with OpenVDB in the new Remesh modifier by the way), and Voxel Remesh gave a slightly better result (slightly more balanced topology).

Jeacom you can focus on armature feature. Having a way of building easily rough ‘blocking’ shapes is an essential process in sculpting and Sculpt toolkit is already in a good way towards this direction, so you can make it much better. Zbrush’s related tools can be a good source of inspiration for such a task.

1 Like

What features do you guys think would be worth it so?, something like shadowbox?